summaryrefslogtreecommitdiff
path: root/dev-python/pyzotero/pyzotero-1.5.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-02 11:46:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-02 11:46:02 +0100
commitfade240e5eae2521e59569af4ab63e27415f4e5b (patch)
tree18ce5cd3bed52f77d3ff5fbe8b47a025b6892619 /dev-python/pyzotero/pyzotero-1.5.15.ebuild
parent16c48ec5caa018c82b1db0f23542c29893f9b919 (diff)
gentoo auto-resync : 02:10:2023 - 11:46:02
Diffstat (limited to 'dev-python/pyzotero/pyzotero-1.5.15.ebuild')
-rw-r--r--dev-python/pyzotero/pyzotero-1.5.15.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyzotero/pyzotero-1.5.15.ebuild b/dev-python/pyzotero/pyzotero-1.5.15.ebuild
new file mode 100644
index 000000000000..f3a14dc2a090
--- /dev/null
+++ b/dev-python/pyzotero/pyzotero-1.5.15.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python client for the Zotero API"
+HOMEPAGE="
+ https://github.com/urschrei/pyzotero/
+ https://pypi.org/project/pyzotero/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/zotero-bin
+ dev-python/bibtexparser[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-6[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest