summaryrefslogtreecommitdiff
path: root/dev-python/pyxdg/pyxdg-0.26-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-20 15:11:50 +0000
commit16449a80e28af2209916cc66d19c9a44ca2b90d9 (patch)
treeb4cfe2332c7a6c5da27b6985bf05db4508df1a92 /dev-python/pyxdg/pyxdg-0.26-r1.ebuild
parent79599515788b85b18aa655e7b7f8cc05c1bbddd8 (diff)
gentoo resync : 20.02.2019
Diffstat (limited to 'dev-python/pyxdg/pyxdg-0.26-r1.ebuild')
-rw-r--r--dev-python/pyxdg/pyxdg-0.26-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyxdg/pyxdg-0.26-r1.ebuild b/dev-python/pyxdg/pyxdg-0.26-r1.ebuild
new file mode 100644
index 000000000000..f8810a58d4ea
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.26-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
+inherit distutils-r1
+
+MY_P=${PN}-rel-${PV}
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="https://freedesktop.org/wiki/Software/pyxdg https://cgit.freedesktop.org/xdg/pyxdg/"
+# official mirror of the git repo
+SRC_URI="https://github.com/takluyver/pyxdg/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-themes/hicolor-icon-theme
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ nosetests -v || die
+}