summaryrefslogtreecommitdiff
path: root/dev-python/pyxattr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-14 09:29:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-14 09:29:38 +0000
commit05a3b7c2189f095dfc46fbb03d4b3e801d3dc13a (patch)
tree46ab17fba7d43e3132d97ee97ebd604dea996018 /dev-python/pyxattr
parentc73b611d606bc14760bad8592f5bfec28c9b1079 (diff)
gentoo auto-resync : 14:12:2022 - 09:29:38
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/Manifest2
-rw-r--r--dev-python/pyxattr/pyxattr-0.8.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyxattr/Manifest b/dev-python/pyxattr/Manifest
index 5e916fcd37f6..363809c33a91 100644
--- a/dev-python/pyxattr/Manifest
+++ b/dev-python/pyxattr/Manifest
@@ -1,3 +1,5 @@
DIST pyxattr-0.7.2.tar.gz 31550 BLAKE2B 3505300d7a50dc305068740379bb8edbefa29f228c797e2e74467a51f4b0a6b740203f89b8ed461218978214213a6cd778107f58eb07a64d6b45e25d0fb769ea SHA512 fb9b36d5d2fb9ab674daf40d6f5c7dbe50d847dcb6d9955d270ef3aed2d8e3540f8feebd934009f47d63f3c55882846a20f7ed733b0d0c004e7a1984e7106206
+DIST pyxattr-0.8.0.tar.gz 35720 BLAKE2B 776cacc68a2dc3e9d60b026d9d0dd3b3ff362445c8f9eb205d1799378b1cb1ab0e6af5fe9bc4f295e428195d0431287f62f6fb735a37831e3b36b7f53f5535a6 SHA512 921af6341cdfdfccea0c46e02742d051de00c7eca75c52f9fcc1618217c41869da957dd6ce03fa7d1367b86b44b49b5263ba65de277bf2453807c6f69a67141b
EBUILD pyxattr-0.7.2.ebuild 833 BLAKE2B 6959b68b43d3b9377dffe705e0a4925f0e9c6ebde4641d951c01c4cd3a50b7e9bb566c6b8fdd2a8d3055542347f69be08b543092e57b28c00e9ed37a02d6a110 SHA512 abac72117c700b6045fd9f8014f2109cb5a2d108fd22e38e8be7e4e4e96b93dcc945223badc501a7ab928c33f141775cd8d39149b08192206404b7a6dacbc8ab
+EBUILD pyxattr-0.8.0.ebuild 902 BLAKE2B aac44aa69dfe736cb898d65abd21942deb84626863d7b6d210d1a2fee0b998ad3a632cd41f922407a44670226d959c581be26fc8ea87bedd4798266ff61e028e SHA512 201958dbe8154b93bd4e544c681e5ce55c41c939e680062ffae41eb2057a2d7de5efc781cac49384c6031dd26ccc5d6fdbac114335cee24384379fcd44cb379f
MISC metadata.xml 668 BLAKE2B 4464bbef18d4eedbc1309c009e0679ae4a6a5870416802e4ad7bdd3814ec1cc1f741386c1bb44578e5ae67c6da978645a5a14c14e74e58ac928708bbf09f5a4a SHA512 7efd22b5b2a920c4725558bce7ca44dd84106001e716188b28eedc7f4718d28b542f647fe8d9e0b58ec9037461745df323589f187933ea73947e6c9e5b59ede8
diff --git a/dev-python/pyxattr/pyxattr-0.8.0.ebuild b/dev-python/pyxattr/pyxattr-0.8.0.ebuild
new file mode 100644
index 000000000000..ae35e41fcdb6
--- /dev/null
+++ b/dev-python/pyxattr/pyxattr-0.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to xattr"
+HOMEPAGE="
+ https://pyxattr.k1024.org/
+ https://github.com/iustin/pyxattr/
+ https://pypi.org/project/pyxattr/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ sys-apps/attr:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/recommonmark
+
+python_prepare_all() {
+ sed -i -e 's:, "-Werror"::' setup.py || die
+ # Bug 548486
+ sed -e "s:html_theme = 'default':html_theme = 'classic':" \
+ -i doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}