summaryrefslogtreecommitdiff
path: root/dev-python/pywlroots/pywlroots-0.16.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-09 00:04:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-09 00:04:30 +0100
commit94ead5b3c01213a82c9b72a2df165452421db42b (patch)
tree8a48ed4d21de4204607288d00e68a671bef1e8f8 /dev-python/pywlroots/pywlroots-0.16.6.ebuild
parent418459f7de9eb29d6db8b61681f39c467d9600e1 (diff)
gentoo auto-resync : 09:10:2023 - 00:04:30
Diffstat (limited to 'dev-python/pywlroots/pywlroots-0.16.6.ebuild')
-rw-r--r--dev-python/pywlroots/pywlroots-0.16.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pywlroots/pywlroots-0.16.6.ebuild b/dev-python/pywlroots/pywlroots-0.16.6.ebuild
new file mode 100644
index 000000000000..15d6d590ef3f
--- /dev/null
+++ b/dev-python/pywlroots/pywlroots-0.16.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python binding to the wlroots library using cffi"
+HOMEPAGE="
+ https://github.com/flacjacket/pywlroots/
+ https://pypi.org/project/pywlroots/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+# See README for wlroots dep
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+ >=dev-python/pywayland-0.4.14[${PYTHON_USEDEP}]
+ >=dev-python/xkbcommon-0.2[${PYTHON_USEDEP}]
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+ x11-base/xwayland
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.24-no-import-version-check.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf wlroots || die
+ epytest
+}