summaryrefslogtreecommitdiff
path: root/dev-python/pywinrm/pywinrm-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /dev-python/pywinrm/pywinrm-0.3.0.ebuild
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'dev-python/pywinrm/pywinrm-0.3.0.ebuild')
-rw-r--r--dev-python/pywinrm/pywinrm-0.3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pywinrm/pywinrm-0.3.0.ebuild b/dev-python/pywinrm/pywinrm-0.3.0.ebuild
new file mode 100644
index 000000000000..7fc926f49b0c
--- /dev/null
+++ b/dev-python/pywinrm/pywinrm-0.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Windows Remote Management through Python"
+HOMEPAGE="https://pypi.org/project/pywinrm/"
+SRC_URI="mirror://pypi/p/pywinrm/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-credssp[${PYTHON_USEDEP}]
+ dev-python/requests-kerberos[${PYTHON_USEDEP}]
+ dev-python/requests-ntlm[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"