summaryrefslogtreecommitdiff
path: root/dev-python/pywavelets/pywavelets-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-18 11:02:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-18 11:02:30 +0000
commitce89e807ecd2194613ad6e6bcee8cf95e982ad1a (patch)
tree5664e77b09dcdec8263e4a0ebbf87da3e1524e87 /dev-python/pywavelets/pywavelets-1.5.0.ebuild
parent7e6812aaf62d1be61aaa50252c7e868fc9eabf4c (diff)
gentoo auto-resync : 18:11:2023 - 11:02:29
Diffstat (limited to 'dev-python/pywavelets/pywavelets-1.5.0.ebuild')
-rw-r--r--dev-python/pywavelets/pywavelets-1.5.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pywavelets/pywavelets-1.5.0.ebuild b/dev-python/pywavelets/pywavelets-1.5.0.ebuild
new file mode 100644
index 000000000000..7fa30d61d3e0
--- /dev/null
+++ b/dev-python/pywavelets/pywavelets-1.5.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYPI_PN="PyWavelets"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Discrete Wavelet Transforms in Python"
+HOMEPAGE="
+ https://pywavelets.readthedocs.io/en/latest/
+ https://github.com/PyWavelets/pywt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ <dev-python/numpy-2[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.22.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-python/cython-0.29.35[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pywt || die
+ epytest --pyargs pywt
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docinto examples
+ dodoc -r demo
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}