summaryrefslogtreecommitdiff
path: root/dev-python/pyvorbis
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyvorbis
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyvorbis')
-rw-r--r--dev-python/pyvorbis/Manifest5
-rw-r--r--dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch65
-rw-r--r--dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch20
-rw-r--r--dev-python/pyvorbis/metadata.xml8
-rw-r--r--dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild38
5 files changed, 136 insertions, 0 deletions
diff --git a/dev-python/pyvorbis/Manifest b/dev-python/pyvorbis/Manifest
new file mode 100644
index 000000000000..61b8c6acc258
--- /dev/null
+++ b/dev-python/pyvorbis/Manifest
@@ -0,0 +1,5 @@
+AUX pyvorbis-1.4-python25.patch 1562 BLAKE2B 4735697a7f75f6ef825ae22769d226d69bd10aee71653bef0ce3b2573dad670105683259fece3225aa7625265a72b33a996520ec6c7b96d7f94b1c0a36e6b2a8 SHA512 9d8e6dfd5e72ccaa2cc4fe67941d44fd607824d94b8f9b62d69bda7abd05abe08f10492f2ddc8b2c11c11371417861f22af48411d51b9d81973dfd6e1af3f631
+AUX pyvorbisfile.c-1.4.patch 564 BLAKE2B 6efa9eaf588ec47227bdb3d90157c7a746818d79900de88135ba9c357098e7ad306454c0e1fe18f097e4b1eb87b68badf03f984d1626e39d756c467e14f732e3 SHA512 73426fc32dac932e548555eebbac3a2c2ca252f18882eb815d40da4238b3e0e544e993d395e2c0df04dcc6d2e7b9cdcb6f26417390d91c6ef11c24530dfa7ce1
+DIST pyvorbis-1.4.tar.gz 39045 BLAKE2B 57fe96085cfed822ee3277d59b6d8e0bb3c5b88a92c615da2159a23eab74b0ba30c693e1b3b41716c7eb4dcfbfe332956535845360a6c6b19df95c73f9634fba SHA512 c0b5ebb5d22f97b20f56a0b49e43675764fe057afa2d5de22eab9b8b73fb542186e7488cb0ba31b7af433cef1a88e815eb3e88a4609a2657ae5fba1017bdb89c
+EBUILD pyvorbis-1.4-r4.ebuild 938 BLAKE2B 3e04c9fa87b4ef48cab6d47060f16255ea62444e708576e9ea1cec467cab7b58fa7688878df52afd4d87a6c5dfb8b30d5795be44bfe528a4700cad1eac8c726e SHA512 7d8185be7469e483fcf83eda9305d58aa4c650df4c2e1b3f038f6d74535fce1fd9045a58b3f52b50e816929a630a46c5a4fa53dd642b262e7d158ddaa42470d3
+MISC metadata.xml 236 BLAKE2B 167eb58da19caba0e03167e2f209e118ce8a468851bca2790a0353112848fffcd72522497e5f951bf5c6eafa9691fa2a1ad980843cb4170a8194f3b8178ebe16 SHA512 0f2c2a0401b53543eac90eafdd4d11c5913be07f47b968e2892ca92c265adbd9564f02a491ff2607d7031194ba3e50c7720851537341b1541120821c487147a3
diff --git a/dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch b/dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch
new file mode 100644
index 000000000000..18028dc7a8e7
--- /dev/null
+++ b/dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch
@@ -0,0 +1,65 @@
+diff -ur pyvorbis-1.4-old/src/pyvorbiscodec.c pyvorbis-1.4/src/pyvorbiscodec.c
+--- pyvorbis-1.4-old/src/pyvorbiscodec.c 2003-05-13 11:17:13.000000000 +0300
++++ pyvorbis-1.4/src/pyvorbiscodec.c 2007-09-20 01:57:54.000000000 +0300
+@@ -118,7 +118,7 @@
+ {
+ vorbis_dsp_clear(PY_DSP(self));
+ Py_XDECREF(((py_dsp *)self)->parent);
+- PyMem_DEL(self);
++ PyObject_Del(self);
+ }
+
+ static PyObject*
+@@ -447,7 +447,7 @@
+ {
+ vorbis_block_clear(PY_BLOCK(self));
+ Py_XDECREF(((py_block *)self)->parent);
+- PyMem_DEL(self);
++ PyObject_Del(self);
+ }
+
+ static PyObject*
+diff -ur pyvorbis-1.4-old/src/pyvorbisfile.c pyvorbis-1.4/src/pyvorbisfile.c
+--- pyvorbis-1.4-old/src/pyvorbisfile.c 2003-12-19 09:11:02.000000000 +0200
++++ pyvorbis-1.4/src/pyvorbisfile.c 2007-09-20 01:59:41.000000000 +0300
+@@ -173,8 +173,7 @@
+ if (ret == NULL) {
+ PyMem_DEL(newobj);
+ return NULL;
+- } else
+- Py_DECREF(ret);
++ }
+
+ return (PyObject *) newobj;
+ }
+@@ -195,7 +194,8 @@
+ fclose(py_self->c_file);
+ }
+
+- PyMem_DEL(self);
++ free(py_self->ovf);
++ PyObject_Del(self);
+ }
+
+ static PyObject *
+diff -ur pyvorbis-1.4-old/src/pyvorbisinfo.c pyvorbis-1.4/src/pyvorbisinfo.c
+--- pyvorbis-1.4-old/src/pyvorbisinfo.c 2003-12-19 09:51:36.000000000 +0200
++++ pyvorbis-1.4/src/pyvorbisinfo.c 2007-09-20 02:01:58.000000000 +0300
+@@ -134,7 +134,7 @@
+ static void
+ py_ov_info_dealloc(PyObject *self)
+ {
+- PyMem_DEL(self);
++ PyObject_Del(self);
+ }
+
+ #define CMP_RET(x) \
+@@ -418,7 +418,7 @@
+ free(ovc_self->vc);
+ }
+
+- PyMem_DEL(self);
++ PyObject_Del(self);
+ }
+
+
diff --git a/dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch b/dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch
new file mode 100644
index 000000000000..5d1d8ffc7c77
--- /dev/null
+++ b/dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch
@@ -0,0 +1,20 @@
+--- src/pyvorbisfile.c.orig 2003-12-19 07:11:02.000000000 +0000
++++ src/pyvorbisfile.c 2005-09-03 20:02:19.000000000 +0100
+@@ -190,9 +190,6 @@
+ /* If file was opened from a file object, decref it, so it can
+ close */
+ Py_DECREF(py_self->py_file);
+- } else {
+- /* Otherwise, we opened the file and should close it. */
+- fclose(py_self->c_file);
+ }
+
+ PyMem_DEL(self);
+@@ -260,7 +257,6 @@
+
+ retval = ov_open(file, self->ovf, initial, ibytes);
+
+- self->c_file = file;
+ if (retval < 0) {
+ if (fname != NULL)
+ fclose(file);
diff --git a/dev-python/pyvorbis/metadata.xml b/dev-python/pyvorbis/metadata.xml
new file mode 100644
index 000000000000..9e5274c5b4ae
--- /dev/null
+++ b/dev-python/pyvorbis/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild b/dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild
new file mode 100644
index 000000000000..a52d1665ce48
--- /dev/null
+++ b/dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Python bindings for the ogg.vorbis library"
+HOMEPAGE="http://ekyo.nerim.net/software/pyogg/"
+SRC_URI="http://ekyo.nerim.net/software/pyogg/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-python/pyogg-1.1[${PYTHON_USEDEP}]
+ >=media-libs/libogg-1.0
+ >=media-libs/libvorbis-1.0"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS COPYING ChangeLog NEWS README )
+PATCHES=(
+ "${FILESDIR}/pyvorbisfile.c-1.4.patch"
+ "${FILESDIR}/${P}-python25.patch"
+)
+
+python_configure_all() {
+ tc-export CC
+ "${PYTHON}" config_unix.py --prefix /usr || die "Configuration failed"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*
+}