summaryrefslogtreecommitdiff
path: root/dev-python/pyusb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyusb
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyusb')
-rw-r--r--dev-python/pyusb/Manifest3
-rw-r--r--dev-python/pyusb/metadata.xml15
-rw-r--r--dev-python/pyusb/pyusb-1.0.2.ebuild30
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyusb/Manifest b/dev-python/pyusb/Manifest
new file mode 100644
index 000000000000..4d2240590056
--- /dev/null
+++ b/dev-python/pyusb/Manifest
@@ -0,0 +1,3 @@
+DIST pyusb-1.0.2.tar.gz 68694 BLAKE2B 8910d9d6d7abd8b0dddf725ad9cc745ce5b06f69a4824a86ed9783918d0fc88d438674852288654964c4555d8278f22d3daab679149c64ea8a6fd3dd2f1cf284 SHA512 6a264b796e17612004196a7a526a7c6df99feac9062f8354540221016411a78a65d413731aea2fc1206ed5ea2b84787078898b9ca3754164f1dfe2a9878b75a5
+EBUILD pyusb-1.0.2.ebuild 818 BLAKE2B e3b49a12d4d391320ca2b6ca115bb51440696a7c4caa284abfca21bd130104906d8dcd85bf8a85734c34ca0b2f4dbfe524047828e73e3ec4511be34c63717859 SHA512 bb977061feafa963ecff88a7498617b45d3ef219ea6003a25cbc2212ae47504b3e5b8f54a1ca61da8db8a5cb86ec3f5b602a5d70fb5549cc41abfbe21447eff1
+MISC metadata.xml 472 BLAKE2B bae31bb84443c5d215f931618d90cabbc11633d90a1dea5e29ade93e42671b4bf1cd037f235e9a58059d2571b0e9b32f0261508108bc6678544dc09f3293b8da SHA512 7db6620b2545b31d9dd3c3844f9d02d0403c266a931935ec8e5728bb936ed3ec1f5ec5fd5d7146668e4e17c9f8f1eb31affaaec90dc93e690864b574a7ddbc4c
diff --git a/dev-python/pyusb/metadata.xml b/dev-python/pyusb/metadata.xml
new file mode 100644
index 000000000000..7a1db2dc3782
--- /dev/null
+++ b/dev-python/pyusb/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ pyusb is a python wrapper for the libusb user space USB device library.
+ </longdescription>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyusb</remote-id>
+ <remote-id type="github">walac/pyusb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyusb/pyusb-1.0.2.ebuild b/dev-python/pyusb/pyusb-1.0.2.ebuild
new file mode 100644
index 000000000000..ac5eea3c5d85
--- /dev/null
+++ b/dev-python/pyusb/pyusb-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="USB support for Python"
+HOMEPAGE="https://walac.github.io/pyusb/ https://pypi.org/project/pyusb/"
+SRC_URI="https://github.com/walac/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# pypi releases don't include tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+### This version is compatible with both 0.X and 1.X versions of libusb
+DEPEND="virtual/libusb:=
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS="README.rst docs/tutorial.rst"
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" testall.py || die "Tests failed with ${EPYTHON}"
+}