summaryrefslogtreecommitdiff
path: root/dev-python/pyupgrade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-19 02:35:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-19 02:35:40 +0100
commitd1989de9d66ba4285e46f80cd571d5a82beae871 (patch)
treefa3f0e9d6020a1e887247ba335438e405b83bcc5 /dev-python/pyupgrade
parentf252a808abf092f718fbdfabb1c9b3ce51e62551 (diff)
gentoo auto-resync : 19:08:2022 - 02:35:40
Diffstat (limited to 'dev-python/pyupgrade')
-rw-r--r--dev-python/pyupgrade/Manifest3
-rw-r--r--dev-python/pyupgrade/metadata.xml21
-rw-r--r--dev-python/pyupgrade/pyupgrade-2.37.3.ebuild20
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/Manifest b/dev-python/pyupgrade/Manifest
new file mode 100644
index 000000000000..4de5f58c22cc
--- /dev/null
+++ b/dev-python/pyupgrade/Manifest
@@ -0,0 +1,3 @@
+DIST pyupgrade-2.37.3.gh.tar.gz 64041 BLAKE2B 531ac8038c7084a4e46bac15d8da056d04496d979beb1fa98ab0832fab50425f412e3b17de3a52a24264acf489af9a9dde6094dd8a5939877269b38d1997d9ad SHA512 dd7e31c2e586d412902d25f30102dc7d229f76f4735e61ad9c77ad59642c2c2ed65d937cc5c6cde9bd50a1a2dad99d06a97c88fb6b0bd034cbc139685045f738
+EBUILD pyupgrade-2.37.3.ebuild 579 BLAKE2B 23b27bcceeed4c3a8d94bdeb3eb5ad97bed4d02e2c0bfb2b5c0811e72d3d5085eb35fef8adb6cfee14e8528479935898d36612e23ff1e7b13ac41b6d45aec32e SHA512 cba4069b225a210287bd79ade8bf89836a95d85a94c9dc1dffdcbf18f1573eab55f3d4bead5ec90b0c0448e9718f41a7c596b26d4a2d8a34faf3ad8fb449ca1e
+MISC metadata.xml 598 BLAKE2B 0efa6bc0c32378e116c4c1a37458be82add617d76b8b11e41947d26fc6eaa08c7c0069e05f2fc67f7903f580d6915d7b973657ed5bc186ef08533da958cc0070 SHA512 c220e724cf228be4ffad4c5f20d2cd58a084dc0d1483111a4250ddd3798b19b6074a829e8cd75cdc8b82e97b8b7e1cf02c7ba19da133c507953dc5f7166a267a
diff --git a/dev-python/pyupgrade/metadata.xml b/dev-python/pyupgrade/metadata.xml
new file mode 100644
index 000000000000..f072f4d85273
--- /dev/null
+++ b/dev-python/pyupgrade/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ajak@gentoo.org</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pypi</remote-id>
+ <remote-id type="github">asottile/pyupgrade</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyupgrade/pyupgrade-2.37.3.ebuild b/dev-python/pyupgrade/pyupgrade-2.37.3.ebuild
new file mode 100644
index 000000000000..568af18a9d08
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-2.37.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="A tool (and pre-commit hook) to automatically upgrade syntax for newer versions of the language."
+HOMEPAGE="https://github.com/asottile/pyupgrade"
+SRC_URI="https://github.com/asottile/pyupgrade/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/tokenize-rt[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest