summaryrefslogtreecommitdiff
path: root/dev-python/pyupgrade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-31 10:44:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-31 10:44:36 +0100
commit53aea9d709c9286028405b25584181507f47442f (patch)
treee7b1ada98149b1cc40791b5bb7616d133d80d46c /dev-python/pyupgrade
parent358368569cfce7dc6be9a6faed29805babe0e371 (diff)
gentoo auto-resync : 31:07:2023 - 10:44:36
Diffstat (limited to 'dev-python/pyupgrade')
-rw-r--r--dev-python/pyupgrade/Manifest2
-rw-r--r--dev-python/pyupgrade/pyupgrade-3.10.1.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/Manifest b/dev-python/pyupgrade/Manifest
index ab3f50f9f920..fc5afd7b320a 100644
--- a/dev-python/pyupgrade/Manifest
+++ b/dev-python/pyupgrade/Manifest
@@ -1,3 +1,5 @@
+DIST pyupgrade-3.10.1.gh.tar.gz 63457 BLAKE2B 54c3105b4e84025e8204b29abeaec813e7959f21bfe1d4d5dfef4caae355885a4be0459685b05eb38266ec4bd14f1736304c404f14c909f51bb554e249f9906c SHA512 47579a1116a56f64dc190956ce708a4a99ae93bdc446a060b2a6418b026ff249d53dc98a5e5153203af2f00f6a1335bc66908e1ae8ead1ad957edf35854cfa8c
DIST pyupgrade-3.9.0.gh.tar.gz 63231 BLAKE2B 5b8bcba1d5f20379a2fe12df3f515222ccf05a67c6666c9de9caddc2f667010eec296f5c64354dbd56170a94f3cba00e0556f34c5f0cc2ffcc4e3a289790d24f SHA512 572f5b30ce18d86ed2e0cae102cc05940e58be325e0dffb4d5c23e7ed377e497d74c01f44d2bf32a18d04eaed282df5007f5f9eea5633fc46f196c63a6fcc134
+EBUILD pyupgrade-3.10.1.ebuild 649 BLAKE2B 07fbabc1cfd716958c5d26bcbc938408020902b3dacebde6d94cfd8339de24f9802381d2008c12b014c53ce5f99889f676b83e60ee06b116e30be64d7660fc28 SHA512 ae689cca97b7fb13dcc124ae5c97f5ac9b2159efa64a2f0a741cb6de120aa34da03365d6602af6bbaa340d10616dfb398d9dd6415599bae6ecbcdf1726370fc1
EBUILD pyupgrade-3.9.0.ebuild 641 BLAKE2B 103f33a5355845e6a073b3525181f8ca6db914e17cf68fca24cba79b086c536573cf8c1ccd8496a913bef0eccc2a2c8d09730dcc73db7c0fb33fbcffc05e4bfe SHA512 0997f770c8056c86261da7271bd30a4b6335dad90c7d6fbb00dd53729656bb968c29f28d9f294a2be1a647271bcb9304363a29c8b2aa95b87f26a0eca3414820
MISC metadata.xml 603 BLAKE2B a9513a08115930ae37b1a3dc5bd2c0649e646bfdad961f10478b9575c597ffad2847b13642e9433ed7ffa41a2ffae0410616e7eb1cc2a00dfdc181f98639419a SHA512 f9da5ac513c1ee7e1411642119344abf4d409bffc2b1cac997bee625add8ceb5982931d9cddeee082d1943f405a70bea617b06b3bbc6f3787ea987b8e43554b1
diff --git a/dev-python/pyupgrade/pyupgrade-3.10.1.ebuild b/dev-python/pyupgrade/pyupgrade-3.10.1.ebuild
new file mode 100644
index 000000000000..19a841ef7eff
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-3.10.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="
+ https://github.com/asottile/pyupgrade/
+ https://pypi.org/project/pyupgrade/
+"
+# no tests in sdist, as of 3.3.2
+SRC_URI="
+ https://github.com/asottile/pyupgrade/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/tokenize-rt-5.2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest