summaryrefslogtreecommitdiff
path: root/dev-python/pyupgrade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-26 12:14:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-26 12:14:51 +0100
commit218cd7b08b8b97198d02f1ba811d540421367139 (patch)
tree8e54a3dcab9a16b30e15a9789d23933365fdd62c /dev-python/pyupgrade
parentd5d36fc823b7189d033e69314ae2764f1eed9168 (diff)
gentoo auto-resync : 26:04:2023 - 12:14:51
Diffstat (limited to 'dev-python/pyupgrade')
-rw-r--r--dev-python/pyupgrade/Manifest2
-rw-r--r--dev-python/pyupgrade/pyupgrade-3.3.2.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/Manifest b/dev-python/pyupgrade/Manifest
index 51fa24a52e4d..1374f7bd4c97 100644
--- a/dev-python/pyupgrade/Manifest
+++ b/dev-python/pyupgrade/Manifest
@@ -1,3 +1,5 @@
DIST pyupgrade-3.3.1.gh.tar.gz 62720 BLAKE2B e1b1d899bb46871f0a28ac3423efbcbd91e0bbdac2ab3054fc19434c67a8702e4967d3cd7674284022e7b7847dc947c8d1736eeee78d8a9416de2b7c25eae715 SHA512 1f062a884061e77ec11e6dd1cc1bedd2680b443b1268b30a9f6bfa2954ef3ff8a6dd1108abdb3a9b0acc937456fe6621a5ad3b9e9ad5c1696e95d0903859ff5f
+DIST pyupgrade-3.3.2.gh.tar.gz 62698 BLAKE2B 5dc1d9e9ea7b91cb2835ffdbc109fb4fcde629f375c49714cf52fe779b20a61f38f13321a14803636e759ac8a4460e768c4173c6608da1cf7cd44a3a347660e9 SHA512 6436286a9398d9cae8c5e9cff2104c43638cafb866a1b97794c1d20cadc078ae5a657d1b83512461d20d2f581b8f8fbbb2ee4d0516f8e75d562c5934be4966e5
EBUILD pyupgrade-3.3.1.ebuild 600 BLAKE2B dc5cdc612040d908d449a6236d309e204fdedf5d23e26d0606887d98e223f147aab1b7cb1a81785d96b47847b0fcfa837e1dbd861574881e331fb2a34067f90e SHA512 d4992e7058082702ce3a6e3749d6d9843406303d47ba8a055f441f02673e62e9fd2ced64884edcdb4b3cc169136744061d96b8eba1709969ec1bcc5e60c56f0a
+EBUILD pyupgrade-3.3.2.ebuild 633 BLAKE2B ccbca0cdadf8e9941db018b32494b78bb842e4d0c72d5213cc04029f86aa889ac9d4ec2050bff54e43db50be06d554564aeccb710eb2fccfa4f85ffe503783db SHA512 44e831955abaf32d488c9de3d42cbf62093ca58d05b44564c4c8ade395f80bf32a1b2f1f5a7fedf60bef35db776459d8a6df16d4bde8e49aada33b322b8530f8
MISC metadata.xml 603 BLAKE2B a9513a08115930ae37b1a3dc5bd2c0649e646bfdad961f10478b9575c597ffad2847b13642e9433ed7ffa41a2ffae0410616e7eb1cc2a00dfdc181f98639419a SHA512 f9da5ac513c1ee7e1411642119344abf4d409bffc2b1cac997bee625add8ceb5982931d9cddeee082d1943f405a70bea617b06b3bbc6f3787ea987b8e43554b1
diff --git a/dev-python/pyupgrade/pyupgrade-3.3.2.ebuild b/dev-python/pyupgrade/pyupgrade-3.3.2.ebuild
new file mode 100644
index 000000000000..e9dec0883fc1
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-3.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="
+ https://github.com/asottile/pyupgrade/
+ https://pypi.org/project/pyupgrade/
+"
+# no tests in sdist, as of 3.3.2
+SRC_URI="
+ https://github.com/asottile/pyupgrade/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/tokenize-rt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest