summaryrefslogtreecommitdiff
path: root/dev-python/pyupgrade/pyupgrade-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 14:59:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 14:59:59 +0000
commit529abfa74a08ae5099db9780bcdf8250aa52ecb6 (patch)
tree2e2d1a9fd6e89b4872499afea3dc57490271e69c /dev-python/pyupgrade/pyupgrade-3.3.0.ebuild
parente6ba529df30e3fc9dfdf55ec5797f2f764df6e54 (diff)
gentoo auto-resync : 03:12:2022 - 14:59:58
Diffstat (limited to 'dev-python/pyupgrade/pyupgrade-3.3.0.ebuild')
-rw-r--r--dev-python/pyupgrade/pyupgrade-3.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/pyupgrade-3.3.0.ebuild b/dev-python/pyupgrade/pyupgrade-3.3.0.ebuild
new file mode 100644
index 000000000000..02368726bb1d
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-3.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="
+ https://github.com/asottile/pyupgrade/
+ https://pypi.org/project/pyupgrade/
+"
+SRC_URI="
+ https://github.com/asottile/pyupgrade/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/tokenize-rt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest