summaryrefslogtreecommitdiff
path: root/dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild')
-rw-r--r--dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild b/dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild
new file mode 100644
index 000000000000..28c95ccfeac2
--- /dev/null
+++ b/dev-python/pytz_deprecation_shim/pytz_deprecation_shim-0.1.0_p0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+
+DESCRIPTION="Shims to make deprecation of pytz easier"
+HOMEPAGE="https://pypi.org/project/pytz-deprecation-shim/ https://github.com/pganssle/pytz-deprecation-shim"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytzdata[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' python3_8 pypy3)
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme