summaryrefslogtreecommitdiff
path: root/dev-python/pytools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-23 00:06:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-23 00:06:40 +0100
commitb3b92de25c3fc5f6bddc5e513027140591a0b2a5 (patch)
treef2ce6d7e747abea3e8fa7d99e32ad5d98cf33988 /dev-python/pytools
parent236e75597883501f8700d9ba1a5c8276f578a17f (diff)
gentoo auto-resync : 23:05:2024 - 00:06:39
Diffstat (limited to 'dev-python/pytools')
-rw-r--r--dev-python/pytools/Manifest2
-rw-r--r--dev-python/pytools/pytools-2024.1.3.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytools/Manifest b/dev-python/pytools/Manifest
index 9b64a23f7d26..dfcff3a6849c 100644
--- a/dev-python/pytools/Manifest
+++ b/dev-python/pytools/Manifest
@@ -1,3 +1,5 @@
DIST pytools-2024.1.2.tar.gz 77642 BLAKE2B b393149a81a708f3681b34e88e22113223f53f23e83c8f1848d4fd6ec456af7145fba8a98efd716d8be5b6184fc9973c05aa9c0814d48ee4925255b57f6119a5 SHA512 3252b3930934c43f840a77f41e0958fef6121db1d64efc5498defadf8e48fdbda89d1539b87b6367c8acf4ad7eaf7fdf364263340ffebd834861f0f21f1af4c7
+DIST pytools-2024.1.3.tar.gz 79453 BLAKE2B 00d19b5e3918ae2e230db8778edcbaa8102436be1d82ee0a24f5f7504ef5f8ca5903c07386b5ebb1359138d4cb2f68840585b30e118f5dc1f3e2266230ec7d1d SHA512 89ee628af18ab68ebc1dab500a886cad243333a0ebf85128c1b06608b51638fc713e2d485b8d50bd3c70ab3143c46e789a49f7f7fc4fa8a14dd9644e7a822d72
EBUILD pytools-2024.1.2.ebuild 831 BLAKE2B 68eac5e0f37e04d831864417ccffe9fe38c4b925f386743c8b25928799ad1aa1367dcd99679efc607f29dc32d8774eb0ac403f4667d94735bb85024a345b7d32 SHA512 6d72857ea97f8085679b14296dbb1b8a67ea03c265e10be43c98a362b408e3af58afbfe05b17fbb89ff1ba2f9c31a7cd3c4ee4348c2ec565a198bf174f64a2ba
+EBUILD pytools-2024.1.3.ebuild 833 BLAKE2B d6b8a51354d5663a4017f18c0b0350bb7db9acb2a6a695384202b4a4c774ea8096333bd51c9423c348f725abfa529818d7b5ff41bfa2070fcf66bbd96e077f1a SHA512 455fdea9a18fb4f6f49e1d65fac941bc2718e671bcdc0ca32d97e8991e9104329cf984a5fab58a8166178e43acff5b81cd38337b6350a4676a9104c78a8e6da9
MISC metadata.xml 496 BLAKE2B d0067ed5726907ed3d635fc88dc33722335e7c853ee4a5a1c727faecdf6a78ab7de4261fe40c5c903908e1f2b8eb597ff3c014044fc7ea02bc357254d544da64 SHA512 c6b546564e9c54bccc55f83310ff194192be0673bfe552e18e29a82e87d2caf4c0d51e42d1675cf5b8f6dff1fa1410676f71c9c0c56273ba6efc4efc608c43d9
diff --git a/dev-python/pytools/pytools-2024.1.3.ebuild b/dev-python/pytools/pytools-2024.1.3.ebuild
new file mode 100644
index 000000000000..38860936dd01
--- /dev/null
+++ b/dev-python/pytools/pytools-2024.1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="
+ https://mathema.tician.de/software/pytools/
+ https://github.com/inducer/pytools/
+ https://pypi.org/project/pytools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+
+# NB: numpy is now an "extra" (optional) dep -- we can remove it from
+# RDEPEND If revdeps don't need it
+RDEPEND="
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest