summaryrefslogtreecommitdiff
path: root/dev-python/pytoml/pytoml-0.1.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-python/pytoml/pytoml-0.1.18.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-python/pytoml/pytoml-0.1.18.ebuild')
-rw-r--r--dev-python/pytoml/pytoml-0.1.18.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytoml/pytoml-0.1.18.ebuild b/dev-python/pytoml/pytoml-0.1.18.ebuild
new file mode 100644
index 000000000000..d08273e5ccc0
--- /dev/null
+++ b/dev-python/pytoml/pytoml-0.1.18.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+TOML_TEST_COMMIT="fa9501a192b7c46b82059caddaef978e3de883dc"
+
+DESCRIPTION="A TOML-0.4.0 parser/writer for Python"
+HOMEPAGE="https://github.com/avakar/pytoml"
+SRC_URI="https://github.com/avakar/pytoml/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/avakar/toml-test/archive/${TOML_TEST_COMMIT}.tar.gz -> toml-test-${TOML_TEST_COMMIT}.tar.gz )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ cp -R ../toml-test-${TOML_TEST_COMMIT}/* test/toml-test/ || die
+ ${EPYTHON} test/test.py || die
+}