summaryrefslogtreecommitdiff
path: root/dev-python/pytimeparse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pytimeparse
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pytimeparse')
-rw-r--r--dev-python/pytimeparse/Manifest2
-rw-r--r--dev-python/pytimeparse/pytimeparse-1.1.8-r1.ebuild (renamed from dev-python/pytimeparse/pytimeparse-1.1.8.ebuild)17
2 files changed, 6 insertions, 13 deletions
diff --git a/dev-python/pytimeparse/Manifest b/dev-python/pytimeparse/Manifest
index ea1589436b60..719f1d9e31d8 100644
--- a/dev-python/pytimeparse/Manifest
+++ b/dev-python/pytimeparse/Manifest
@@ -1,3 +1,3 @@
DIST pytimeparse-1.1.8.tar.gz 9403 BLAKE2B 671a96f0f7d517e6cd137b8ec7bda17976993a683ece5e06f857cb07063cd4d7fdd08a98f838dbf35251a8403b68f7dc538e5450db3abe644e8c7c4f6c76b645 SHA512 9eb4530d779b940d66412920eefa4f4d3c43719aa3e4104da4f337c05421bcbb6ad4cb2d6459ddfac770fc9f19960a9d8ce578e67f2513499a7bee8efe9541ec
-EBUILD pytimeparse-1.1.8.ebuild 653 BLAKE2B c0a653a8eff39bc3490601ea744d0023aa2ed66c5908725f49677b5552c8897072d53f716b30bf24c34d5bf7f8f83fd364809c361f0ed80708a6c2c80dfe2d81 SHA512 3d5a6399d3734baf680b5b5f5afb7359b51b85ecbc4e078d36ff9f6fd1ca04c161f6d88b7a15d2f61a08d38f799893c1fb7b6031c77152d7da48eb8f64419897
+EBUILD pytimeparse-1.1.8-r1.ebuild 498 BLAKE2B 9aeada4248de898b4ae3774ecb747ae3b05e4e70f5542484d0d1d87882bb14538fece59161bcc4ce0156242e80110009ce5f009f129097e10ac3a7ea89b44a56 SHA512 120ba958202bb5f8af01e2860b55b2234e69d4c76853b02e646c544bef27ee63823850e286cbdf6a5bf06c04b5fc4236b53d595f97e7d0050987f17c5fddbca0
MISC metadata.xml 501 BLAKE2B 9ad6298b97c2882d63f95eebd4e055745b736b15b28c9268096b08e8a1376169614795b2b5138ae03fdb22c75be6c30776bc8b998955b88aaf1b3ab2ee60d44c SHA512 2a01bcf9ca0e6a9b285f5aff31e05e8b31c00487ddb09036c69d86fcdd3c28ce89f89a309d9510436a0b27bf922778f46914b215918ed9e1ab9b31887d1e08b2
diff --git a/dev-python/pytimeparse/pytimeparse-1.1.8.ebuild b/dev-python/pytimeparse/pytimeparse-1.1.8-r1.ebuild
index 536667deb9cd..307c17920bb5 100644
--- a/dev-python/pytimeparse/pytimeparse-1.1.8.ebuild
+++ b/dev-python/pytimeparse/pytimeparse-1.1.8-r1.ebuild
@@ -1,25 +1,18 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="A small Python module to parse various kinds of time expressions"
HOMEPAGE="https://github.com/wroberts/pytimeparse https://pypi.org/project/pytimeparse/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
-python_test() {
- local unittest_args=(
- --verbose
- --locals
- pytimeparse.tests.testtimeparse
- )
-
- "${PYTHON}" -m unittest "${unittest_args[@]}" || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests unittest