summaryrefslogtreecommitdiff
path: root/dev-python/pythran
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-python/pythran
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/Manifest3
-rw-r--r--dev-python/pythran/files/pythran-0.10.0-tests-werror.patch11
-rw-r--r--dev-python/pythran/pythran-0.10.0.ebuild6
3 files changed, 18 insertions, 2 deletions
diff --git a/dev-python/pythran/Manifest b/dev-python/pythran/Manifest
index 6615026fb68d..9919ee2af1b2 100644
--- a/dev-python/pythran/Manifest
+++ b/dev-python/pythran/Manifest
@@ -1,3 +1,4 @@
+AUX pythran-0.10.0-tests-werror.patch 480 BLAKE2B ac7b6fe2cd4b4aeed3be4baf2a433ff48ae9e2bedc7be70c04122bf097906480e57d077ed485e0e47c6414d390e64fdef47d5ef77a890af99403defcc43b0bc8 SHA512 e699298e03b5d0e868aa2704100f47368baf2477c4f3632d97f1c65af0ff6babbbecab3c083f09f09353194dedc3b77b653b1b8ae9ac7967ebc65c8932bf8bdf
DIST pythran-0.10.0.gh.tar.gz 3614984 BLAKE2B 82686479d475c6814392eb6c34e2d765ba36c88f9de3119f38c81b3f09d07acce8f5ab11b31114c13a1aa3bebd3699c540edcc6203401a007caf02c960a4733b SHA512 3d48d6f12fcd0317cb756eee18ad359057e4daee1a496023253b26febd2acf0fd22c3b4976bc8552a137d25052e4feaacf1917c5dc84414e9fbed66dff5c1614
-EBUILD pythran-0.10.0.ebuild 1133 BLAKE2B 357974cfd1bf983d98b25b8c7bbfd1707bea51fa24befd290c8c895d72767bf18cae768cc7d19473140500a1655a7c96958924f1ef54198aab290366abfc07d5 SHA512 8503342f1152543cbb71078f90a2ae4455a6d26434c07919806090342910d2c1af23ba7f52281750997496cb3fa9c47596b32840e0d71c71dbac462411c94de9
+EBUILD pythran-0.10.0.ebuild 1202 BLAKE2B cbf0b0fadfde536d580571388560018f7b2243c43f96cfb9262e6785f290e935150b23dff53acbc63eb20e04ee7a09b9791614ce345b9c63fdb1d74b3867e87a SHA512 bd137d37169104489506fa444953e78f3753485492cda8656ba3d97e5d19df091911e49f9c8b88873a3e86bc68f4536537e08702b247e596139065f23f5fab79
MISC metadata.xml 354 BLAKE2B e7ec71fae294f6f697b0fd99b0ccef24049af7999866344e8da2ebc40bc2988a21f2cb0374b52b781a5f8b55f26ebca364dc93f4e69d957a3ff6bd3c32cd988d SHA512 9008d270ea6757557482edb55c5848aea9a29abfbbad65d93000660a1e51ad2456a2b7ccfcacb80da23b3dd38cee2c4da9645aed48a35edb4a497bbe3a80dd7f
diff --git a/dev-python/pythran/files/pythran-0.10.0-tests-werror.patch b/dev-python/pythran/files/pythran-0.10.0-tests-werror.patch
new file mode 100644
index 000000000000..17c0630a5d1e
--- /dev/null
+++ b/dev-python/pythran/files/pythran-0.10.0-tests-werror.patch
@@ -0,0 +1,11 @@
+--- a/pythran/tests/__init__.py
++++ b/pythran/tests/__init__.py
+@@ -71,7 +71,7 @@ class TestEnv(unittest.TestCase):
+
+ module = pytest.mark.module
+ # default options used for the c++ compiler
+- PYTHRAN_CXX_FLAGS = ['-O0', '-Wall', '-Werror', '-UNDEBUG',
++ PYTHRAN_CXX_FLAGS = ['-O0', '-Wall', '-UNDEBUG',
+ '-Wno-unused-function',
+ '-Wno-int-in-bool-context',
+ '-Wno-unknown-warning-option',
diff --git a/dev-python/pythran/pythran-0.10.0.ebuild b/dev-python/pythran/pythran-0.10.0.ebuild
index 7b1b66240e45..e3b071b43344 100644
--- a/dev-python/pythran/pythran-0.10.0.ebuild
+++ b/dev-python/pythran/pythran-0.10.0.ebuild
@@ -18,7 +18,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm arm64 ~riscv ~sparc x86"
RDEPEND="
=dev-python/beniget-0.4*[${PYTHON_USEDEP}]
@@ -36,6 +36,10 @@ BDEPEND="
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.0-tests-werror.patch
+)
+
src_prepare() {
sed -i -e '/pytest-runner/d' setup.py || die
distutils-r1_src_prepare