summaryrefslogtreecommitdiff
path: root/dev-python/pythran
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-06 11:33:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-06 11:33:44 +0100
commit0e52cbae2c719c3ef794ebeb0f4374fb96efcff3 (patch)
tree7e5732a7869c402a96586eca1ff1b574e59a328f /dev-python/pythran
parent0922e7f160098c343e6e41a5e167a69b9e035db6 (diff)
gentoo auto-resync : 06:05:2023 - 11:33:44
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/Manifest2
-rw-r--r--dev-python/pythran/pythran-0.12.2.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pythran/Manifest b/dev-python/pythran/Manifest
index 142d464962b3..e5ae02887086 100644
--- a/dev-python/pythran/Manifest
+++ b/dev-python/pythran/Manifest
@@ -1,5 +1,7 @@
DIST pythran-0.12.1.gh.tar.gz 3631063 BLAKE2B c680639a88cd63398f88ee6f5325da288c06549bfef2ee649e27dd92114a2690f54fb3da730c4eb30ff9b7ef297c219bafa5f7f7153b7710d348859a04716e84 SHA512 05c4e1d03de3eebccbb915e13c70a36de293152aece58066f2d91d483d3ac920d61c7a76adcb2337f60e637734451775f0fc61341b0ef9fc4f074a752e39de9d
+DIST pythran-0.12.2.gh.tar.gz 3631092 BLAKE2B 5c7c9aadd1351fbfd1368b2957ad5952338aaf41bc124caad4243538f325599d50eeda12383a41e2bff0245ab2ecda3a27254d98d3e09f929d3d28856d556cd3 SHA512 2f83a2cda04dbdf55dcb6f5f1f43e9bb39668fa9f568ed39760a360f59f65b1e7e1f313d26efcb530fad34e69cc8dfb5aa38747943daa8d06d00b2610a1a7be5
DIST pythran-0.13.1.gh.tar.gz 3639196 BLAKE2B 8aba73c68542d69dd2287d7081226161ecade9e49fe6ea69d034f9116becbc148614212cbcff0056291809d2994caf43ee374393939e44635c6bed69220b29b8 SHA512 2497fa49d78ff64e577816f4b48bd424c03f04b7605c92d359f0f8514aaa67b30b7e68248db475c215deafaf7e55f7b4b74ab37c9dbef2a27e813878bf350e77
EBUILD pythran-0.12.1.ebuild 1532 BLAKE2B 4fea6f91b125cf3f8d679d0887ce007d3dcd911dbfab69174fe708bafdc1baeeee0ef68d33e10ef498b5d60446ccfca262bf5b1213127fca19aaba8d6a977be1 SHA512 78ea63912cc58f004870050b817e70c2b6105ecb5757bcb57ece8ec58873b33f92f355d9035c8e5f62446113ded274e16011a19d95eb46408f888d07364b911c
+EBUILD pythran-0.12.2.ebuild 1533 BLAKE2B c0d06b33214d61e7f6e9699234dbdb2b62cbe7f8e7b8479f3f75317e2934942186ab14340e5153321e0a8266ee5ffccdff8b7de8673a899a538389c4eec5ba18 SHA512 28341e2f44a9107450872b476d1cd45a0e123faa8d3ce61b8dc8257e8f4035d0767b5d0277a6ca8abe1b7d17a8bea06e1f1a221a2d9401ffce746e8db339ca14
EBUILD pythran-0.13.1.ebuild 1697 BLAKE2B 77a241c9176f3c82b3a31bf6bf12b9a5714f671da9e9b64ddcdf5c612f3d9e792ebad62d14863a927d295fa6daa885fad283353322ce41b788d7c09b7a2574c2 SHA512 12c919c74c1665f83f49bdbfbe3885d50c2206526c04b2f47606eba0bfd63bdd00f5a6e47cbaf9de3a5316b6652b30c3f7bda4dcf2c792703c11e4578bf80438
MISC metadata.xml 354 BLAKE2B e7ec71fae294f6f697b0fd99b0ccef24049af7999866344e8da2ebc40bc2988a21f2cb0374b52b781a5f8b55f26ebca364dc93f4e69d957a3ff6bd3c32cd988d SHA512 9008d270ea6757557482edb55c5848aea9a29abfbbad65d93000660a1e51ad2456a2b7ccfcacb80da23b3dd38cee2c4da9645aed48a35edb4a497bbe3a80dd7f
diff --git a/dev-python/pythran/pythran-0.12.2.ebuild b/dev-python/pythran/pythran-0.12.2.ebuild
new file mode 100644
index 000000000000..ed7c02739d9e
--- /dev/null
+++ b/dev-python/pythran/pythran-0.12.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{9..11} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
+
+inherit distutils-r1 multiprocessing
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Ahead of Time compiler for numeric kernels"
+HOMEPAGE="
+ https://pypi.org/project/pythran/
+ https://github.com/serge-sans-paille/pythran/
+"
+SRC_URI="
+ https://github.com/serge-sans-paille/pythran/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ia64 ~loong ppc ppc64 ~riscv ~s390 ~sparc x86"
+
+RDEPEND="
+ dev-libs/boost
+ =dev-python/beniget-0.4*[${PYTHON_USEDEP}]
+ <dev-python/gast-0.5.4[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/ipython[${PYTHON_USEDEP}]
+ ' "${PYTHON_TESTED[@]}")
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/cblas
+ !!dev-python/setuptools-declarative-requirements
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # TODO: package xsimd then set no_xsimd = True
+ cat >> setup.cfg <<-EOF
+ [build_py]
+ no_boost = True
+ EOF
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ pythran/tests/test_xdoc.py::TestDoctest::test_cli
+ pythran/tests/test_xdoc.py::TestDoctest::test_toolchain
+ )
+
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs)"
+}