summaryrefslogtreecommitdiff
path: root/dev-python/pythran
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-24 14:47:38 +0100
commitb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (patch)
tree911928b566777494d08ebe2c16cb64f15af71901 /dev-python/pythran
parent61f10f985e19dfe20a4d9552902625edd5b6eabb (diff)
gentoo resync : 24.06.2021
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/Manifest3
-rw-r--r--dev-python/pythran/metadata.xml11
-rw-r--r--dev-python/pythran/pythran-0.9.11.ebuild48
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pythran/Manifest b/dev-python/pythran/Manifest
new file mode 100644
index 000000000000..5bfad814a2f4
--- /dev/null
+++ b/dev-python/pythran/Manifest
@@ -0,0 +1,3 @@
+DIST pythran-0.9.11.gh.tar.gz 3570395 BLAKE2B deada9a608ed3d883308389d5a6ddfee2f0f74ecc74f1fd87bcee75eecabcab2acd576425b8e92d6fc6b212377f1c7295e766db32082339c98670a964a49ea10 SHA512 c8939b918216803ad8e2a133b16f0d8ea939e4d87d07ddb1a3d131afb0ddb76962c489270431808fbf129e76b5f9dbdc2b625097f37df2eefdb9834d319d028a
+EBUILD pythran-0.9.11.ebuild 1183 BLAKE2B 7c810169aff4d52fe1d23dcbb0dcf75a61f342ae4b2e7f47b01c8ae966389638cb38700bf06fa3e1285d8664706dbb6c6bbcef528a0e76652bb0bf5b8d5b0dd7 SHA512 53c038ee10e4411ade77b3917554f46a38354cd4855e854df6842654f4ba3d6c3ab616d4898ba164bfea2c9b38939ea2aee8b7adc6ecca25625534bdea7fde6b
+MISC metadata.xml 353 BLAKE2B 3584e4357ca55b22b1bf1c707b22df13999c358ce3968fd968c2cb94db6014e325b6782b8bb2b6e97a7a6c584081fa974ddf01ea88103b51cbd0bd2b49300bb4 SHA512 13435a1f1b2de15e825165e9d71ad3f12f29f32fe55694b7e504b76a5b6738bf4ff7b2626b0c956a1edb66d744b3589dac320eca4af0db5e6c55f3ddf537550f
diff --git a/dev-python/pythran/metadata.xml b/dev-python/pythran/metadata.xml
new file mode 100644
index 000000000000..852515482ce4
--- /dev/null
+++ b/dev-python/pythran/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">serge-sans-paille/pythran</remote-id>
+ <remote-id type="pypi">pythran</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pythran/pythran-0.9.11.ebuild b/dev-python/pythran/pythran-0.9.11.ebuild
new file mode 100644
index 000000000000..e9f0d52d41d0
--- /dev/null
+++ b/dev-python/pythran/pythran-0.9.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Ahead of Time compiler for numeric kernels"
+HOMEPAGE="
+ https://pypi.org/project/pythran/
+ https://github.com/serge-sans-paille/pythran/"
+SRC_URI="
+ https://github.com/serge-sans-paille/pythran/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/beniget-0.3*[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ =dev-python/gast-0.4*[${PYTHON_USEDEP}]
+ >=dev-python/networkx-2[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/cblas
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/pytest-runner/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}