summaryrefslogtreecommitdiff
path: root/dev-python/pythran/pythran-0.14.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
commitf8999218b5a6eafa151e7367030cbfdb69e045ed (patch)
tree0d0e9293bcb75153cd18542369fa789ede9338a0 /dev-python/pythran/pythran-0.14.0.ebuild
parentaa4954f71a3ba2293395a8cce2321a70c39c7554 (diff)
gentoo auto-resync : 25:05:2024 - 00:07:14
Diffstat (limited to 'dev-python/pythran/pythran-0.14.0.ebuild')
-rw-r--r--dev-python/pythran/pythran-0.14.0.ebuild91
1 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/pythran/pythran-0.14.0.ebuild b/dev-python/pythran/pythran-0.14.0.ebuild
deleted file mode 100644
index 21cf7d416363..000000000000
--- a/dev-python/pythran/pythran-0.14.0.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_TESTED=( pypy3 python3_{10..12} )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-
-inherit distutils-r1 multiprocessing
-
-MY_P=${P/_p/.post}
-DESCRIPTION="Ahead of Time compiler for numeric kernels"
-HOMEPAGE="
- https://pypi.org/project/pythran/
- https://github.com/serge-sans-paille/pythran/
-"
-SRC_URI="
- https://github.com/serge-sans-paille/pythran/archive/${PV/_p/.post}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv ~s390 ~sparc x86"
-
-RDEPEND="
- dev-libs/boost
- =dev-python/beniget-0.4*[${PYTHON_USEDEP}]
- =dev-python/gast-0.5*[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/ply-3.4[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-libs/boost
- dev-cpp/xsimd
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/ipython[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- virtual/cblas
- !!dev-python/setuptools-declarative-requirements
- )
-"
-
-distutils_enable_tests pytest
-
-src_configure() {
- cat >> setup.cfg <<-EOF || die
- [build_py]
- no_boost = True
- no_xsimd = True
- EOF
-
- if use test ; then
- sed -i \
- -e 's|blas=blas|blas=cblas|' \
- -e 's|libs=|libs=cblas|' \
- pythran/pythran-*.cfg || die
- fi
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- pythran/tests/test_xdoc.py::TestDoctest::test_cli
- pythran/tests/test_xdoc.py::TestDoctest::test_toolchain
- # Tries to invoke pip
- pythran/tests/test_distutils.py::TestDistutils::test_setup_build
- pythran/tests/test_distutils.py::TestDistutils::test_setup_build2
- )
-
- case ${EPYTHON} in
- python3.12)
- EPYTEST_DESELECT+=(
- # requires numpy.distutils
- pythran/tests/test_distutils.py::TestDistutils::test_setup_{b,s}dist_install3
- )
- ;;
- esac
-
- local -x COLUMNS=80
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p xdist -n "$(makeopts_jobs)"
-}