summaryrefslogtreecommitdiff
path: root/dev-python/pythonnet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 23:49:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 23:49:25 +0000
commitfdc0e69ff470f51130dba7c7a539210ceedf9e6d (patch)
treec17533ac33965d5b150997aa149cb1c35ad777d6 /dev-python/pythonnet
parent28d8acbb30a9ebda81447e5e3f5210a438ba7d24 (diff)
gentoo auto-resync : 30:01:2024 - 23:49:25
Diffstat (limited to 'dev-python/pythonnet')
-rw-r--r--dev-python/pythonnet/Manifest2
-rw-r--r--dev-python/pythonnet/pythonnet-3.0.3.ebuild8
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/pythonnet/Manifest b/dev-python/pythonnet/Manifest
index cd43a2411fb9..c5956fa5b3f9 100644
--- a/dev-python/pythonnet/Manifest
+++ b/dev-python/pythonnet/Manifest
@@ -187,5 +187,5 @@ DIST system.xml.xmldocument.4.3.0.nupkg 285212 BLAKE2B 0d96ca356543e8e915597e062
DIST system.xml.xpath.4.3.0.nupkg 250182 BLAKE2B 8a4177d47af56bc7a6289ed8f2cac41d504dee212a858ed221277b3f523b1ce38ccb47bc3ce4d59a2c7cfd77f00f3c9693a9c257c90adb38096ee77a860f10cc SHA512 2bd0979a2020579fb32ad374b89929a272e763ee1233ed9a215408c0a1f9f82a5fdb74330c1c55a6102e0dfdb8b7b59ed25fdf6454bf3de146152ea779f366e0
DIST system.xml.xpath.xdocument.4.3.0.nupkg 89906 BLAKE2B b15b21497207c788ab23bb4f80af85044770087b25623285da5081989dc1608730a1b5040e32b7c080b98ed790b010237a6e295351d5ec27ef66e0b21ed405a0 SHA512 06ac9786b2f20b1336f3f56a3c97536907d033f1a9b9ec07267192f60ed51732924aa366f481e862f1f63d75fabdc5de51b445c5cb6c36f1fb89690a29b6e1e8
DIST system.xml.xpath.xmldocument.4.3.0.nupkg 138523 BLAKE2B ba53f3b5ac0f2d1d1e9120940b302e6960690ed4a44b96ba15b03e16f9159f2c57d6004aa55b796ba2327009d23fc2f10d4d09e948b88eb6af36efa5f76e401b SHA512 f75b6f7c75874ab6053e8942c1662a6e9a3561aa01502437b8d67f3bfcebd1ebf906792801326889ed7acb094c55469766d7d27cd10bc61b46ddaaa94dfc11e3
-EBUILD pythonnet-3.0.3.ebuild 8957 BLAKE2B ca99e4907df450ede0f5e4d1ff0ed825a59f6bd9d04e926e99fb9d5e2a4097702ac9ade8fd08b3127d4c3f0e0d01ba48bbe85f35171567f8af581bb9da55fc82 SHA512 101dba87c41c68ea0f3dd1aa01ec3eab6a28b4e83de6f4a7011e6a316fdf0510ac2945a3c39a000f6c11d772e067683bf7bea5f808a89e2223e6ce979b826a25
+EBUILD pythonnet-3.0.3.ebuild 8995 BLAKE2B 8f68b7ef3bcd83e3dd04aa2c0119a4d85741ff630c34877d176a89bb76e9fc7cb2ad36ed23e92e8c028bf860dd383afce3b79f00fea4564e11bd39ba6c0367d8 SHA512 0d18cc62e4dae8f50176786b065970a0713fb8ca27ca09819ebc82bd14de8d29ca59d5b4d3f8fc8bd18c45a48c6050927c8c29878147da978ca33d47177fb758
MISC metadata.xml 839 BLAKE2B fa42872a2798187950878b69062519a2aff30454ca6a56869370beae252725696e3401bd224b9cf540fc714af9ac1dda6c97f35f94fb8dfb26bbd03e7a524003 SHA512 0daf97ddca9195329e77932920c5a1f4048ed7e2a24e38eccaa14550cf4f91e31b7a8411750dddc0ce7267b917de834ca2326243879292332a0c1ed48d97b0c4
diff --git a/dev-python/pythonnet/pythonnet-3.0.3.ebuild b/dev-python/pythonnet/pythonnet-3.0.3.ebuild
index 3e4e1fb66d51..8f82e2daedb9 100644
--- a/dev-python/pythonnet/pythonnet-3.0.3.ebuild
+++ b/dev-python/pythonnet/pythonnet-3.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -230,9 +230,8 @@ BDEPEND="
"
CHECKREQS_DISK_BUILD="1500M"
-PATCHES=( "${FILESDIR}/${PN}-3.0.3-no-sourcelink.patch" )
-
EPYTEST_DESELECT=(
+ 'tests/test_codec.py::test_sequence'
'tests/test_engine.py::test_import_module'
'tests/test_engine.py::test_run_string'
'tests/test_method.py::test_getting_method_overloads_binding_does_not_leak_memory'
@@ -240,6 +239,9 @@ EPYTEST_DESELECT=(
'tests/test_module.py::test_assembly_load_recursion_bug'
'tests/test_module.py::test_implicit_assembly_load'
)
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.3-no-sourcelink.patch"
+)
DOCS=( AUTHORS.md CHANGELOG.md README.rst )
DOC_CONTENTS="Python.NET defaults to the mono runtime, not .NET SDK's coreclr.