summaryrefslogtreecommitdiff
path: root/dev-python/python3-saml/python3-saml-1.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-09 18:06:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-09 18:06:43 +0100
commit4e4ee9865a958b6a854f9bca96637244c628d525 (patch)
tree824d75c3a55f71fc978cdd1fca5cb03ff439e59c /dev-python/python3-saml/python3-saml-1.16.0.ebuild
parentc65def1225a421dd57ac582acefc5987c9d67e0d (diff)
gentoo auto-resync : 09:10:2023 - 18:06:43
Diffstat (limited to 'dev-python/python3-saml/python3-saml-1.16.0.ebuild')
-rw-r--r--dev-python/python3-saml/python3-saml-1.16.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python3-saml/python3-saml-1.16.0.ebuild b/dev-python/python3-saml/python3-saml-1.16.0.ebuild
new file mode 100644
index 000000000000..cf677a8893b4
--- /dev/null
+++ b/dev-python/python3-saml/python3-saml-1.16.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="OneLogin's SAML Python Toolkit"
+HOMEPAGE="
+ https://github.com/SAML-Toolkits/python3-saml/
+ https://pypi.org/project/python3-saml/
+"
+SRC_URI="
+ https://github.com/SAML-Toolkits/python3-saml/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/isodate-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.9.0[${PYTHON_USEDEP}]
+ >=dev-python/xmlsec-1.3.9[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet
+ tests/src/OneLogin/saml2_tests/idp_metadata_parser_test.py::OneLogin_Saml2_IdPMetadataParser_Test::testGetMetadataWithHeaders
+ tests/src/OneLogin/saml2_tests/idp_metadata_parser_test.py::OneLogin_Saml2_IdPMetadataParser_Test::testParseRemoteWithHeaders
+ )
+
+ # The tests are horribly fragile to paths.
+ local -x PYTHONPATH=src
+ epytest -o 'python_files=*_test.py'
+}