summaryrefslogtreecommitdiff
path: root/dev-python/python3-openid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python3-openid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python3-openid')
-rw-r--r--dev-python/python3-openid/Manifest3
-rw-r--r--dev-python/python3-openid/metadata.xml11
-rw-r--r--dev-python/python3-openid/python3-openid-3.1.0.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/python3-openid/Manifest b/dev-python/python3-openid/Manifest
new file mode 100644
index 000000000000..2f3d8435adf1
--- /dev/null
+++ b/dev-python/python3-openid/Manifest
@@ -0,0 +1,3 @@
+DIST python3-openid-3.1.0.tar.gz 299326 BLAKE2B 809e38cb20be9dcbb520a17a99758554f33f6f94b98b3deee4507eac0d8724c370a48c7b267f473e3b31e90593b1ef7702eb5d8adfc908c532ba624139da0b23 SHA512 9c96efd16191ddb6ddb12c4885a2cce523244d04e70f9418144d0124ef142fd7b6578cd2a01e949995d7dedf0b96cbb3b17d1d3a29db5da8934f7fa875ad8e9c
+EBUILD python3-openid-3.1.0.ebuild 694 BLAKE2B 32d84d5fc02283a3e6769ce779bfdcd874f2fa068799850c0c9bdd1bfa7a94392a0b86fd71597e5cc9bd6ad4508b554abe1209708f89c09ceb235cb0b12a05e6 SHA512 4b8f624d6c08b7cc20a02c29d3dc832e7a960fc7a31c4bc133b2d5c9bbc6c4fb9df4381063d9dfd666e931d7327568aa5296548d730ab01994db80a5443f543c
+MISC metadata.xml 337 BLAKE2B fd9b6c6e99251249623c019892e1962b2212f8781efb18935a9e9f6da8ac836e114b84758d43529a51e3260981621f8d5c5c17f8ffec7e8b1c34d2c2e335e531 SHA512 099dc2e5cd089e1638ad20bc476cd8d9e6d173b22611f48b34b9945f92886550f53d86ca672882bd570cd6515c33a2d8b4acb87fbd35abfbc55bd592b570459c
diff --git a/dev-python/python3-openid/metadata.xml b/dev-python/python3-openid/metadata.xml
new file mode 100644
index 000000000000..5e866c63a84e
--- /dev/null
+++ b/dev-python/python3-openid/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">necaris/python3-openid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python3-openid/python3-openid-3.1.0.ebuild b/dev-python/python3-openid/python3-openid-3.1.0.ebuild
new file mode 100644
index 000000000000..c584951cc4a9
--- /dev/null
+++ b/dev-python/python3-openid/python3-openid-3.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 port of the python-openid library"
+HOMEPAGE="https://github.com/necaris/python3-openid https://pypi.org/project/python3-openid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/defusedxml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ ${EPYTHON} -m unittest -v openid.test.test_suite || die "Tests failed with ${EPYTHON}"
+}