summaryrefslogtreecommitdiff
path: root/dev-python/python-zipstream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:30:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:30:24 +0100
commitd56d144655e3785864da43c9acb6c228ef9360ae (patch)
treeb769b599a558483f82e9a057c41f1edd29626dd1 /dev-python/python-zipstream
parentfab849d1daed0ba7f2ac497d07985c3dbb692543 (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'dev-python/python-zipstream')
-rw-r--r--dev-python/python-zipstream/Manifest4
-rw-r--r--dev-python/python-zipstream/metadata.xml4
-rw-r--r--dev-python/python-zipstream/python-zipstream-1.1.4.ebuild5
3 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/python-zipstream/Manifest b/dev-python/python-zipstream/Manifest
index dd6ac7e00ec3..f9ac12f3e4fb 100644
--- a/dev-python/python-zipstream/Manifest
+++ b/dev-python/python-zipstream/Manifest
@@ -1,3 +1,3 @@
DIST python-zipstream-1.1.4.tar.gz 21376 BLAKE2B 84b022f93dedfb46da911c3ed800c3a6eb3685bf9c6180b9aac5d4d085748216f53759f83a085fa57f245033281aa4be1578b4051e8a855bcd2300aed7820460 SHA512 722c1d7db91dc47064fc51f1182417f46923b8f42a56e854f1fa125eaccfc7f86d3deab71709226a798a1caf5a84a8a7fa7d3564065ab91afbad434ed787ce32
-EBUILD python-zipstream-1.1.4.ebuild 576 BLAKE2B 2f586e6299b651b3dc8d009a931bc739c143309353d42fb933fb44d3a2852a2f6f6df09446f124b6d10ef8c2b56816e3f2fd3aafda5c3112097e33399f214e18 SHA512 f801cd97e17251c5e5d40d826417653eaf492f31f98b3c53c5b7caf4fd2e18d70f54aee13cbfdc579d8df32d9c26e71b68fe1860af92dff8520f7a0657302e31
-MISC metadata.xml 330 BLAKE2B fb6dc2c8a68446c76a469976699cdadcd3c340e7388fef5f864c23b639f359cf7931498ac76a4544711a8db15c5671b12eaa2cb9604e5904e66909903996516a SHA512 ad1eb74bf656fd0ae144a6f90b1805718dbc7c8dcb5daa6bdd702bc7c1a4f3f9c41a425995a9b67afc5e0847aa0c5297dcb1faa621d7dbb71f3c026a99759533
+EBUILD python-zipstream-1.1.4.ebuild 608 BLAKE2B 5f7f96d81553020d2efddb1101bae9f5e58724bd058e4c325b0796aab33fe92e30130b1d15f361cc1d7b7298e2b43fa8b3d3b9d819452e85886f0dff93436be6 SHA512 27422998b8aaa678b6cf289baed6db17168418d8019d56ecb6592ebee28ecf8e3ab5cb4344fc0106eb42dcd41afda5545dbd1ee5c0b71f9355334b11a3b6333e
+MISC metadata.xml 381 BLAKE2B 04230c4955e69e38535767e64a3bddd5e9732f248e79eb4ca0f12752a8a1e717786866512727f407cb1b7b07d9b954ddedb3c01d5704c99496f4e006cc986c23 SHA512 e08bcfff6419f5fb2ca82c62f3d3280dfebc5dee392b4c63b82ca0ab15c2767e3ac35779b73ec3512c8d822abe94956ca435454f8191a65d52ae8c49d13e6745
diff --git a/dev-python/python-zipstream/metadata.xml b/dev-python/python-zipstream/metadata.xml
index 34e9b246a7aa..c126b28b8044 100644
--- a/dev-python/python-zipstream/metadata.xml
+++ b/dev-python/python-zipstream/metadata.xml
@@ -1,7 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
<upstream>
<remote-id type="github">allanlei/python-zipstream</remote-id>
<bugs-to>https://github.com/allanlei/python-zipstream/issues</bugs-to>
diff --git a/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild b/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild
index 6185735434ed..df1327996cba 100644
--- a/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild
+++ b/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
inherit distutils-r1
@@ -15,10 +15,11 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_test() {
- nosetests || die "tests failed under ${EPYTHON}"
+ nosetests -v || die "tests failed under ${EPYTHON}"
}