summaryrefslogtreecommitdiff
path: root/dev-python/python-zipstream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-zipstream
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-zipstream')
-rw-r--r--dev-python/python-zipstream/Manifest3
-rw-r--r--dev-python/python-zipstream/metadata.xml9
-rw-r--r--dev-python/python-zipstream/python-zipstream-1.1.4.ebuild24
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-zipstream/Manifest b/dev-python/python-zipstream/Manifest
new file mode 100644
index 000000000000..dd01b25df1e5
--- /dev/null
+++ b/dev-python/python-zipstream/Manifest
@@ -0,0 +1,3 @@
+DIST python-zipstream-1.1.4.tar.gz 21376 BLAKE2B 84b022f93dedfb46da911c3ed800c3a6eb3685bf9c6180b9aac5d4d085748216f53759f83a085fa57f245033281aa4be1578b4051e8a855bcd2300aed7820460 SHA512 722c1d7db91dc47064fc51f1182417f46923b8f42a56e854f1fa125eaccfc7f86d3deab71709226a798a1caf5a84a8a7fa7d3564065ab91afbad434ed787ce32
+EBUILD python-zipstream-1.1.4.ebuild 583 BLAKE2B 6e354430d71b73eb93efe20370ac9506158f1d554176d9b360d7f8fdbd5ac143ff13de93bb842c7ee0680719db45ce4e95b3865be2c40684170713fffa4c1156 SHA512 70e561a75c1230b1ddd5deeb2e9716cede10b96b1c09f5fec8fac488d5f6d29252dfd40197ff485acaf9b22287525a936a2f950e41997fdc2ba191e77d26792f
+MISC metadata.xml 330 BLAKE2B fb6dc2c8a68446c76a469976699cdadcd3c340e7388fef5f864c23b639f359cf7931498ac76a4544711a8db15c5671b12eaa2cb9604e5904e66909903996516a SHA512 ad1eb74bf656fd0ae144a6f90b1805718dbc7c8dcb5daa6bdd702bc7c1a4f3f9c41a425995a9b67afc5e0847aa0c5297dcb1faa621d7dbb71f3c026a99759533
diff --git a/dev-python/python-zipstream/metadata.xml b/dev-python/python-zipstream/metadata.xml
new file mode 100644
index 000000000000..34e9b246a7aa
--- /dev/null
+++ b/dev-python/python-zipstream/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">allanlei/python-zipstream</remote-id>
+ <bugs-to>https://github.com/allanlei/python-zipstream/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild b/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild
new file mode 100644
index 000000000000..84ad22d85a23
--- /dev/null
+++ b/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A zip archive generator"
+HOMEPAGE="https://github.com/allanlei/python-zipstream"
+SRC_URI="https://github.com/allanlei/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}