summaryrefslogtreecommitdiff
path: root/dev-python/python-zipstream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-zipstream
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-zipstream')
-rw-r--r--dev-python/python-zipstream/Manifest4
-rw-r--r--dev-python/python-zipstream/metadata.xml9
-rw-r--r--dev-python/python-zipstream/python-zipstream-1.1.4.ebuild24
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-zipstream/Manifest b/dev-python/python-zipstream/Manifest
new file mode 100644
index 000000000000..00090e0685ae
--- /dev/null
+++ b/dev-python/python-zipstream/Manifest
@@ -0,0 +1,4 @@
+DIST python-zipstream-1.1.4.tar.gz 21376 SHA256 32a7a4bdb786914445589595273beffbbf9b6a0a3a3dc2cf19ea96114bd2abd7 SHA512 722c1d7db91dc47064fc51f1182417f46923b8f42a56e854f1fa125eaccfc7f86d3deab71709226a798a1caf5a84a8a7fa7d3564065ab91afbad434ed787ce32 WHIRLPOOL 153e6797cb88bcd1115f8678022061008073f0a33a309b9180e699273940956062ea1c69dd83b6a6a5f4b417405933670949ff09179beb59482866f340af1fd5
+EBUILD python-zipstream-1.1.4.ebuild 583 SHA256 55b38010974fac73b3231311dfdcc7a9ffc8f87f5fb2d702567cb540b435fe30 SHA512 70e561a75c1230b1ddd5deeb2e9716cede10b96b1c09f5fec8fac488d5f6d29252dfd40197ff485acaf9b22287525a936a2f950e41997fdc2ba191e77d26792f WHIRLPOOL c390221c91ed5c05935d0594023899e2d96dd80028ff584fef619c8a3ce1b148e71c99127ffdca69a1b1aa26371f3d5ec8d696d0ab3c810e5fda0340e776a913
+MISC ChangeLog 619 SHA256 f34da36080708c836c54a64c4df2b393f49b71948b73d85b3889742bbf518e58 SHA512 9dc809954069920bf2cdc32a06ca9edf708ae6671db1d42dde2bab3ea4afeae0a173181ea575bebdc9a26376907643b6f4e733247f66f9f3bdb14d3c3f11d5ff WHIRLPOOL 4280f5ca46067d40c552cbf01451b30295f77835af452fa1c9c25c69684b72edefd0e8d94401d14de42bf0d4fd99ad819657ca700328bcd855ebc3426d97f1b6
+MISC metadata.xml 330 SHA256 ba47ebef2a1c9df0e8939ee3c83cd133d04ba54e0dfb30b383c70d4f4523b341 SHA512 ad1eb74bf656fd0ae144a6f90b1805718dbc7c8dcb5daa6bdd702bc7c1a4f3f9c41a425995a9b67afc5e0847aa0c5297dcb1faa621d7dbb71f3c026a99759533 WHIRLPOOL 205df926ccf9ba664e065790778e6b80ba05537296a02582e18c403898a3dc84de2370e1aca16dd253dc9208c176b12d1b03bafc2247d87e9a5063ea178589b0
diff --git a/dev-python/python-zipstream/metadata.xml b/dev-python/python-zipstream/metadata.xml
new file mode 100644
index 000000000000..34e9b246a7aa
--- /dev/null
+++ b/dev-python/python-zipstream/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">allanlei/python-zipstream</remote-id>
+ <bugs-to>https://github.com/allanlei/python-zipstream/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild b/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild
new file mode 100644
index 000000000000..84ad22d85a23
--- /dev/null
+++ b/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A zip archive generator"
+HOMEPAGE="https://github.com/allanlei/python-zipstream"
+SRC_URI="https://github.com/allanlei/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}