summaryrefslogtreecommitdiff
path: root/dev-python/python-zaqarclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/python-zaqarclient
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/python-zaqarclient')
-rw-r--r--dev-python/python-zaqarclient/Manifest2
-rw-r--r--dev-python/python-zaqarclient/python-zaqarclient-1.13.1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-zaqarclient/Manifest b/dev-python/python-zaqarclient/Manifest
index 7cc68f7dcf0c..556411b622cd 100644
--- a/dev-python/python-zaqarclient/Manifest
+++ b/dev-python/python-zaqarclient/Manifest
@@ -1,3 +1,5 @@
DIST python-zaqarclient-1.11.0.tar.gz 85724 BLAKE2B 84e34998a76bd475b3aad2882f076f8ca89dcfc1a24155d0e88269fda3d82d4b1348461d1f59a5f21726dbc56b37219d9e75957737452e759672505a1f16a4c9 SHA512 4b57cd336a6517760d32a5e01a7c87a9ee0526323a222faa6fcd6e33a506b0746d6418e9eee3fa00e7ba4a01912ee108fe1feb3469e0a14089cc760a0756b7fb
+DIST python-zaqarclient-1.13.1.tar.gz 88428 BLAKE2B 71870c7232d4f00b626421fc41e033925fe58f0699538d3e7f3deba2ac07e692d8e676eb763429efcc16ca0c39f8a15317106ca8f6ade583555a89495eba324c SHA512 4854e0a90e98d8172058316fbfcefc0a327a81ae870db28a51264b8e4b809383b652818506f734dd2b35648a544d0811046957c97a86f12d696021d54fbfa890
EBUILD python-zaqarclient-1.11.0.ebuild 1197 BLAKE2B 950d06f78eb5510df2958478b706fa5c7e45b8c0ae13ebba441ba713f12390c2a3ab5730a0b3b40399ee518d495630c49e59fca40d14f38434b202168d9dbc7d SHA512 24089a1cb53adf8feb4c0d81a0457bf468576d72fb51519aba6e69d450e28684ab8274e1a780a7d3c18ff773126afcca41946a6124e3ff8b859d26bddf57ea67
+EBUILD python-zaqarclient-1.13.1.ebuild 1151 BLAKE2B 58ef1068f3d45ed0706d95898689508b60b23497a0133f2415ac7c6b3c2c31c7ca5e29e9c06f0510e3b6fbfab79564cce4db47692e608a8c99ae57b5e89bd74c SHA512 64c9b501a6e1f20ab57fed669ef476131b70b157fb87fc8f70a6dba0f08ee034e696d360741be350e6ea3b797e8034efc39fc5499dd4e80e84b34220d7efa1a1
MISC metadata.xml 607 BLAKE2B 28721f37ce75146475891a79e765fc5ebc12f2e4067b259328fd63fc6aabb16d328d720c2e31cfe538841a638f15e63f141b35a930495e132470cdc0a3777a63 SHA512 73cd47155606b208b2ba83664732ec7fda229f075a86837bae68344bb3fbc10756a049a1f83815f65346d93fbee7a30b629c6769646da2385afab6237173038e
diff --git a/dev-python/python-zaqarclient/python-zaqarclient-1.13.1.ebuild b/dev-python/python-zaqarclient/python-zaqarclient-1.13.1.ebuild
new file mode 100644
index 000000000000..afb54cdfbf28
--- /dev/null
+++ b/dev-python/python-zaqarclient/python-zaqarclient-1.13.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Zaqar API"
+HOMEPAGE="https://github.com/openstack/python-zaqarclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # built in...
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}