summaryrefslogtreecommitdiff
path: root/dev-python/python-xmp-toolkit/python-xmp-toolkit-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-python/python-xmp-toolkit/python-xmp-toolkit-2.0.1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-python/python-xmp-toolkit/python-xmp-toolkit-2.0.1.ebuild')
-rw-r--r--dev-python/python-xmp-toolkit/python-xmp-toolkit-2.0.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/python-xmp-toolkit/python-xmp-toolkit-2.0.1.ebuild b/dev-python/python-xmp-toolkit/python-xmp-toolkit-2.0.1.ebuild
deleted file mode 100644
index 391d15a271c5..000000000000
--- a/dev-python/python-xmp-toolkit/python-xmp-toolkit-2.0.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/python-xmp-toolkit/${PN}.git"
-else
- SRC_URI="https://github.com/python-xmp-toolkit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Library for working with XMP metadata"
-HOMEPAGE="https://github.com/python-xmp-toolkit/python-xmp-toolkit/ https://pypi.org/project/python-xmp-toolkit/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/unittest2[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- media-libs/exempi )"
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}"/${P}-test.patch )
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/.build/html/. )
- distutils-r1_python_install_all
-}