summaryrefslogtreecommitdiff
path: root/dev-python/python-twitter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-twitter
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-twitter')
-rw-r--r--dev-python/python-twitter/Manifest5
-rw-r--r--dev-python/python-twitter/metadata.xml13
-rw-r--r--dev-python/python-twitter/python-twitter-3.3.ebuild37
-rw-r--r--dev-python/python-twitter/python-twitter-3.4.2.ebuild65
4 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/python-twitter/Manifest b/dev-python/python-twitter/Manifest
new file mode 100644
index 000000000000..d2e519062c1a
--- /dev/null
+++ b/dev-python/python-twitter/Manifest
@@ -0,0 +1,5 @@
+DIST python-twitter-3.3.tar.gz 84696 BLAKE2B aad833904e0127fca4043bf66187e7ff5a4175c7c86cf9b053c7d0bc6c9f25d2bc102a631d479ebd4ce81b515aea0f058473993a1b7f5a03751dd83f39e9a3c3 SHA512 72e4133abddf86a19b8701f846df7eb99b426b8835e457455935a656f38c266fb2930d8a145d5d280ef2e0f0096511b29dcdf98b94bd53b6a661ea575cfb3265
+DIST python-twitter-3.4.2.tar.gz 5145121 BLAKE2B 2ac45ae8fde3cfccb794d8496efdb0066c887101b6a6ac55ad6fd0f9fda8f50db1245284236c5fa0fd8eb7419c11eb253777d78092ea138d2f0a5115db861a89 SHA512 23d009e006864bb9dbf9c10223531a0e2aeefd4ca59852849f49f41e36b6db29e820a58c8a43f23c7bda0c68b6eb19a5557ef649bae2cbb1f1e406f78a918f92
+EBUILD python-twitter-3.3.ebuild 885 BLAKE2B a21c8b4368270e23e30e1e097707894a089b2e038264cd6fa2ff509c4661a1ba20dd7132125b21f851c87b9a404457ba7902cecf89103ccfda50c672703f3ea7 SHA512 b38c9d8a3eb38204de4bc968f7a0fb347b4df22a4a06fc2eb437dc3930a52932b2c2afbb75664764a30bc0e3f4f5c497597add698c9de5727b845336df0684af
+EBUILD python-twitter-3.4.2.ebuild 1613 BLAKE2B 352b7218467b6e7ffc421322e7d6ca673750edbce87cd46fde73bd834cfd2ee1a35a0ef60a3fb57650f71419321b67e8828bd94fc6d46b4df5568928d63e4532 SHA512 055709dc1414f4d6596b364757377f41293bfb1cf46d6fc67b5b524d2fedd42da236052d92775c3bda8efbbb9b1f9d9572f34768ec24e90781ecb125f2d10590
+MISC metadata.xml 443 BLAKE2B e04fea3c6771b010c3220bf5e6d2c3d5ef61a99a1f89ce6f1bd220f41c7e2aff1f58a8e93cc30a69e8d638cf5d4c4b6ec254f02541f8de91b09f124cdffd758a SHA512 afd79db4a927e251c94096ca6cb2a6a7fd34abb693b685843b7bbeb0c379ff82feb87ea1ee773ea5939e761cbc4d22f2e61710d286110ed27579316d52df229d
diff --git a/dev-python/python-twitter/metadata.xml b/dev-python/python-twitter/metadata.xml
new file mode 100644
index 000000000000..8b5642ee7b08
--- /dev/null
+++ b/dev-python/python-twitter/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">bear/python-twitter</remote-id>
+ <remote-id type="pypi">python-twitter</remote-id>
+ <bugs-to>https://github.com/bear/python-twitter/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-twitter/python-twitter-3.3.ebuild b/dev-python/python-twitter/python-twitter-3.3.ebuild
new file mode 100644
index 000000000000..4e2bcb224be5
--- /dev/null
+++ b/dev-python/python-twitter/python-twitter-3.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around the Twitter API"
+HOMEPAGE="https://github.com/bear/python-twitter"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/oauth2[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Testsuite is still not convincing in its completeness
+RESTRICT="test"
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+# https://code.google.com/p/python-twitter/issues/detail?id=259&thanks=259&ts=1400334214
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/python-twitter/python-twitter-3.4.2.ebuild b/dev-python/python-twitter/python-twitter-3.4.2.ebuild
new file mode 100644
index 000000000000..e9c653f2de99
--- /dev/null
+++ b/dev-python/python-twitter/python-twitter-3.4.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around the Twitter API"
+HOMEPAGE="https://github.com/bear/python-twitter"
+# Upstream does not include tests or doc in the PyPI tarballs
+# https://github.com/bear/python-twitter/pull/572
+SRC_URI="https://github.com/bear/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE="doc examples test"
+
+# https://bugs.gentoo.org/624916
+RDEPEND="
+ !dev-python/twitter
+ dev-python/oauth2[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/responses-0.6.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ # Not actually required unless we want to do setup.py test
+ # https://github.com/bear/python-twitter/pull/573
+ sed -i "s/'pytest-runner'//" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build doc doc/_build/html || die
+ HTML_DOCS=( doc/_build/html/. )
+ fi
+}
+
+python_test() {
+ py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r examples/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}