summaryrefslogtreecommitdiff
path: root/dev-python/python-systemd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-systemd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-systemd')
-rw-r--r--dev-python/python-systemd/Manifest4
-rw-r--r--dev-python/python-systemd/files/233-xfail-bind.patch31
-rw-r--r--dev-python/python-systemd/metadata.xml10
-rw-r--r--dev-python/python-systemd/python-systemd-233.ebuild36
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/python-systemd/Manifest b/dev-python/python-systemd/Manifest
new file mode 100644
index 000000000000..2b254a50430e
--- /dev/null
+++ b/dev-python/python-systemd/Manifest
@@ -0,0 +1,4 @@
+AUX 233-xfail-bind.patch 1077 BLAKE2B f2fa3f197887d3a14cd7bd2a8bdd33100eb18f4b348bf4ccd1877c843864a71bd52b19d53ed3c98f0de0b690c2158b6ceffe10682ed79c64c829103a2e34fe14 SHA512 63a5325812bb3530a8681b006fc66630a33cc6740ed63171025d4406a68783a3fba0b55141fd9620f049f2225191ce9cffd3d91a9d1c5cef7af94ec82b2ebd6a
+DIST python-systemd-233.tar.gz 49680 BLAKE2B 7d612022738d3114a39f7ad7f4d7799ac3d027980592a5205247d4c866ac3d9520d63ee02f143e26865f0d83338f30422dd0c2299f575e8b03f3112900e9af73 SHA512 92a6cc7123db586e5ae5fbb56e5065b17be9da47ced9dbc5920d80b7db7f56d15b127e72d30889c5b24b119724a33f68be1ef322529620ed95b0f95707e4c2ab
+EBUILD python-systemd-233.ebuild 828 BLAKE2B 6332ff2244a815cfb5dc4a14525d8907a62d98c9a58075556b1211696c488e0db6522e6c39a7129884ec749269da7d954f912d28cf5448ee08843ca0f3cacf38 SHA512 20406f6b507bd7e2b531bb1cf1644dc391e7d5d46a85ed24d4a4ddcc35792a34b155e9baebde21451d2f14f561801ec0acc719dee867fa780a13f88d385a153a
+MISC metadata.xml 306 BLAKE2B 2e77cf6814775cb575c96548a69609034e4d9db62eba44684df463c98fe1b105ae5caffea7e1d05880ad2d8236405b2848fa24bd245e3a8627578d2cb128b055 SHA512 ca004982cde4fe1bcbd821109ec70f464a2014a2c0aa77f9976eedaec78ad68dc8d39e2e2f7023192bf807307e08259548f1ebb298ea7f3654c0b8658fba97f9
diff --git a/dev-python/python-systemd/files/233-xfail-bind.patch b/dev-python/python-systemd/files/233-xfail-bind.patch
new file mode 100644
index 000000000000..bb0fb761bd59
--- /dev/null
+++ b/dev-python/python-systemd/files/233-xfail-bind.patch
@@ -0,0 +1,31 @@
+From 1c0d575f7c058f227d27b1cb92d3936d0c170a5f Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Tue, 21 Feb 2017 17:34:28 -0500
+Subject: [PATCH] test_daemon: xfail test_notify_with_socket if bind() fails
+
+This bind() call may fail if TMPDIR is too long.
+
+Bug: https://bugs.gentoo.org/610368
+---
+ systemd/test/test_daemon.py | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/systemd/test/test_daemon.py b/systemd/test/test_daemon.py
+index e827e1d..7733552 100644
+--- a/systemd/test/test_daemon.py
++++ b/systemd/test/test_daemon.py
+@@ -238,7 +238,10 @@ def test_notify_bad_socket():
+ def test_notify_with_socket(tmpdir):
+ path = tmpdir.join('socket').strpath
+ sock = socket.socket(socket.AF_UNIX, socket.SOCK_DGRAM)
+- sock.bind(path)
++ try:
++ sock.bind(path)
++ except socket.error as e:
++ pytest.xfail('failed to bind socket (%s)' % e)
+ # SO_PASSCRED is not defined in python2.7
+ SO_PASSCRED = getattr(socket, 'SO_PASSCRED', 16)
+ sock.setsockopt(socket.SOL_SOCKET, SO_PASSCRED, 1)
+--
+2.11.1
+
diff --git a/dev-python/python-systemd/metadata.xml b/dev-python/python-systemd/metadata.xml
new file mode 100644
index 000000000000..8986208c5b02
--- /dev/null
+++ b/dev-python/python-systemd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>systemd@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">systemd/python-systemd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-systemd/python-systemd-233.ebuild b/dev-python/python-systemd/python-systemd-233.ebuild
new file mode 100644
index 000000000000..0f7da4e87a05
--- /dev/null
+++ b/dev-python/python-systemd/python-systemd-233.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for native access to the systemd facilities"
+HOMEPAGE="https://github.com/systemd/python-systemd"
+SRC_URI="https://github.com/systemd/python-systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ppc ppc64 sparc x86"
+IUSE="test"
+
+COMMON_DEPEND="
+ sys-apps/systemd:0=
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ !sys-apps/systemd[python(-)]
+"
+
+PATCHES=(
+ "${FILESDIR}"/233-xfail-bind.patch
+)
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" > /dev/null || die
+ "${EPYTHON}" -m pytest -v . || die
+ popd > /dev/null || die
+}