summaryrefslogtreecommitdiff
path: root/dev-python/python-systemd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-19 22:05:27 +0100
commit121ed4eec41fbf03e1998d09eede1bf449da63b9 (patch)
treece9341d77d1507f67d4a3a1472da9011b5baa0a8 /dev-python/python-systemd
parentdd762ff83c330186ee2ede002e08b2f780cddd51 (diff)
gentoo resync : 19.07.2019
Diffstat (limited to 'dev-python/python-systemd')
-rw-r--r--dev-python/python-systemd/Manifest2
-rw-r--r--dev-python/python-systemd/python-systemd-234.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-systemd/Manifest b/dev-python/python-systemd/Manifest
index 982602f6064a..41fb4b9e5749 100644
--- a/dev-python/python-systemd/Manifest
+++ b/dev-python/python-systemd/Manifest
@@ -1,4 +1,6 @@
AUX 233-xfail-bind.patch 1077 BLAKE2B f2fa3f197887d3a14cd7bd2a8bdd33100eb18f4b348bf4ccd1877c843864a71bd52b19d53ed3c98f0de0b690c2158b6ceffe10682ed79c64c829103a2e34fe14 SHA512 63a5325812bb3530a8681b006fc66630a33cc6740ed63171025d4406a68783a3fba0b55141fd9620f049f2225191ce9cffd3d91a9d1c5cef7af94ec82b2ebd6a
DIST python-systemd-233.tar.gz 49680 BLAKE2B 7d612022738d3114a39f7ad7f4d7799ac3d027980592a5205247d4c866ac3d9520d63ee02f143e26865f0d83338f30422dd0c2299f575e8b03f3112900e9af73 SHA512 92a6cc7123db586e5ae5fbb56e5065b17be9da47ced9dbc5920d80b7db7f56d15b127e72d30889c5b24b119724a33f68be1ef322529620ed95b0f95707e4c2ab
+DIST python-systemd-234.tar.gz 53900 BLAKE2B 2658ee7083036ed8259e5f4ad0714ea15227ee836ad34c7fbbdb55dd9df48751b8d9998350d789b4f47e78fe7b4a7134e12d637e5a6ebeb29a0b31e5a4575d91 SHA512 164e34ba46827711e9c6ff9ed58b2706d9a22abfc7001de030ed7d463d8ddf783eb5fee93b207c29950a3c566018cc3f1a21a549421cf3e05c1287b433367eb2
EBUILD python-systemd-233.ebuild 821 BLAKE2B 24faf5079019f64fff7e9c110254b7c8fde43869213ccdfdec26feea99c9d817250b8a0210d1fc31b30595b888183d7c5fa6927fa54f2130d4925f468452a90f SHA512 4322e83de8f7af7dd2a68112680f79601c9f6d0fbbb969964f9159961d23bc0b5321ccd38af7de1628bf5175f86163a4c1d2281e49d0e3c6bd43aa1c15c1974d
+EBUILD python-systemd-234.ebuild 863 BLAKE2B 6b4b008287fc4e16b9786500a447750b73568f9752f3444abf8341dc096ecb53a54bb9110cd715917367c1d916b687962ac5a1a951a0a8ed4f241b575e8f995c SHA512 bcf001df1ef785d13b1d72019c1c7f6015bcff3ff48aa21376d38da3f3371971c0d4f1ac3065e4c8b76a00e46feea449bf2e66a479de907a8f1bd06de53fe2d2
MISC metadata.xml 306 BLAKE2B 2e77cf6814775cb575c96548a69609034e4d9db62eba44684df463c98fe1b105ae5caffea7e1d05880ad2d8236405b2848fa24bd245e3a8627578d2cb128b055 SHA512 ca004982cde4fe1bcbd821109ec70f464a2014a2c0aa77f9976eedaec78ad68dc8d39e2e2f7023192bf807307e08259548f1ebb298ea7f3654c0b8658fba97f9
diff --git a/dev-python/python-systemd/python-systemd-234.ebuild b/dev-python/python-systemd/python-systemd-234.ebuild
new file mode 100644
index 000000000000..978b842ca4bc
--- /dev/null
+++ b/dev-python/python-systemd/python-systemd-234.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for native access to the systemd facilities"
+HOMEPAGE="https://github.com/systemd/python-systemd"
+SRC_URI="https://github.com/systemd/python-systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ sys-apps/systemd:0=
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ !sys-apps/systemd[python(-)]
+"
+
+PATCHES=(
+# "${FILESDIR}"/233-xfail-bind.patch
+)
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" > /dev/null || die
+ pytest -o cache_dir="${T}" -vv || die
+ popd > /dev/null || die
+}