summaryrefslogtreecommitdiff
path: root/dev-python/python-swiftclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-25 00:07:14 +0100
commitf8999218b5a6eafa151e7367030cbfdb69e045ed (patch)
tree0d0e9293bcb75153cd18542369fa789ede9338a0 /dev-python/python-swiftclient
parentaa4954f71a3ba2293395a8cce2321a70c39c7554 (diff)
gentoo auto-resync : 25:05:2024 - 00:07:14
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/Manifest2
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-4.6.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index aff8b6bb31d5..68f9a076190a 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1,3 +1,5 @@
DIST python-swiftclient-4.5.0.tar.gz 207642 BLAKE2B 0b15e5f110143ae7306a0c89a6d1e61907fc00a8dbb5aaaa9dddb5237f756727f114ee7036cf294126b331fd738b67119ea3c4cd68ec8bef8cf19e77a5ba0461 SHA512 95305f09cf4a00c4c0239719b2e6a54ec408bc4b12af9e6e13fb352e313aff65bd865927d4e525fe899ca730a2baf5b4c7827f6f2713d34dc135bf10eaebb6c6
+DIST python-swiftclient-4.6.0.tar.gz 209473 BLAKE2B e35516c4e05c889af5e9e794179b2c5a5fe364bcc85492639dd58c45ffc756d86942038d683e685c9f33d876043c0953c6b0cf69db16abdf57c057cf24ab97ed SHA512 19883c2640cf6071752e09261c7d8499e01b749100e6d79cc3a83e08bffc7392ee852351b11d549001d23898d4c34e8309fdadb8e0241e301bf03300db80eef7
EBUILD python-swiftclient-4.5.0.ebuild 960 BLAKE2B 8a22bcdda23371016e4f42128f7cd5490a4325bfe7a7b2a218ba03dea607ae970b2d2cd4b6e6546f7d3396f3dca27950e4abd8c62744097c5a21ff9b7100e638 SHA512 eff6e22c2ea3288b2f06b6d45acd6d29d54f6da51e9ecc3183ea22e6dba16dc514e710e127545796f9e7f906f39ccfc9efb825cb53534284bccd21fffc0bf85f
+EBUILD python-swiftclient-4.6.0.ebuild 963 BLAKE2B 1b05444d2eaf303e1f637252fe61d9c43df2adfd610cc3092601b8f6b2099d7b4b6d222c5f7aab8325e5da2f37ac2341ec7383ebdfadb9b360a614ab52874623 SHA512 c20128403a6c062065eb3e4cebc97e100dddd469dc8afb0b33f1bd2dd5b13d38569c7deb30f1f28ef7e970429f687e0ac76240cce6864f6fa3167c82a0bec8b4
MISC metadata.xml 668 BLAKE2B 299614e07d6b3f2d4acbc301cfddff8c1699acf3dac104de483e9dafdbf4cb34c8b933fdf7d91de3c26e73f34165338f68b46a44f3a113eb68b9b0270b9819c2 SHA512 f8b012262d487c873552beffe7107c8799bff52b6c61da575a9b2fa82d899d4e30d3a57f0885a119d8aebe87d5be61ea846d0766a409396acaa5fdb2b632e248
diff --git a/dev-python/python-swiftclient/python-swiftclient-4.6.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-4.6.0.ebuild
new file mode 100644
index 000000000000..bea64753a221
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-4.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-swiftclient/
+ https://github.com/openstack/python-swiftclient/
+ https://pypi.org/project/python-swiftclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/keystoneauth1-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.7.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ distutils-r1_python_prepare_all
+}