summaryrefslogtreecommitdiff
path: root/dev-python/python-swiftclient/python-swiftclient-4.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-16 01:44:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-16 01:44:25 +0100
commitd8616435f08981d5bc3df9f348190309a7bdbbc0 (patch)
tree6c51fc295fb9c2f5511a7ebb14fab377a5f8e171 /dev-python/python-swiftclient/python-swiftclient-4.0.1.ebuild
parentfa1962ff69701bd9c0f15fb225cdbfb487125e0e (diff)
gentoo auto-resync : 16:07:2022 - 01:44:25
Diffstat (limited to 'dev-python/python-swiftclient/python-swiftclient-4.0.1.ebuild')
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-4.0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/python-swiftclient-4.0.1.ebuild b/dev-python/python-swiftclient/python-swiftclient-4.0.1.ebuild
new file mode 100644
index 000000000000..2336700dc435
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-4.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="https://launchpad.net/python-swiftclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ # fix duplicate script/entry point
+ # https://bugs.launchpad.net/python-swiftclient/+bug/1975361
+ sed -i -e '/bin\/swift/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}