summaryrefslogtreecommitdiff
path: root/dev-python/python-stdnum/python-stdnum-1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-stdnum/python-stdnum-1.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-stdnum/python-stdnum-1.7.ebuild')
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/python-stdnum-1.7.ebuild b/dev-python/python-stdnum/python-stdnum-1.7.ebuild
new file mode 100644
index 000000000000..6bb1b062dfbf
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="http://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies test"
+
+RDEPEND="vies? ( dev-python/suds )"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+DOCS=( ChangeLog NEWS README )
+
+python_test() {
+ nosetests || die
+}