summaryrefslogtreecommitdiff
path: root/dev-python/python-sqlparse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-python/python-sqlparse
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-python/python-sqlparse')
-rw-r--r--dev-python/python-sqlparse/Manifest2
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.2.4.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/python-sqlparse/Manifest b/dev-python/python-sqlparse/Manifest
index de0cf6c5bdbd..51386fe2e9dc 100644
--- a/dev-python/python-sqlparse/Manifest
+++ b/dev-python/python-sqlparse/Manifest
@@ -1,3 +1,5 @@
DIST sqlparse-0.2.3.tar.gz 60742 BLAKE2B 38d3f17d196d3a1d50ea75810b5bd3a890c6f4b12195621d571d62b8c40e2e2d13034deddd95288df37a15daba28153a5ca9221b78bfff1c0e3bc37eddca2dba SHA512 ec654e680f8ce423a89da92c4c74f85e652bebb19e9a40ab0b8067f61803897e49e1e6f8dd1ab454b1ed130974d76b4f973c799264fd4bf8a87f034ba9c44835
+DIST sqlparse-0.2.4.tar.gz 61614 BLAKE2B 2462fa5d77ca2c3028aa3539bedc3cb2d7abd35db3c736ffd8abad8626a33174787f0079453ec646739749c8860fce0f1c7d815e6a8485c24b851a40b5bf3b87 SHA512 abea0f084778976f2d1086006eaa88e1fc1d2580654d063b35557a44d9d9727b410a022e8ea06ae3b265f2829d49c48d347dddc61f2e56be9c3d6207104712b2
EBUILD python-sqlparse-0.2.3.ebuild 1331 BLAKE2B b2ecb2330cf5b911037b1e6a8c8f01c53d27b927135069e7a3c8d30933811cea92b7003212eff8a334f489bd938933e41940b57ad7152a9c8d6339bb7f5479f3 SHA512 b451f3f61c3831333c59238fa1bad6c03ce9baecf430030b3f55a31939842823b2a30b2004e15935b29621db70f4b20d41754d1e5230f7eb207ec765fc78b921
+EBUILD python-sqlparse-0.2.4.ebuild 1340 BLAKE2B 977c0a499fcd503e4feece3421a1c4f3adfe1c53eb3f93e9aa5dc6910d778c8a1707b8ee20ce2d15d4a38fb30b555eb3781911d0eced85e2212d2307fa057b80 SHA512 ad661a5d94cd20ac16bc0a120abb1994c54212554a8f878e65581d5b7c37d4e17715c5d30f087b3b5ff551b98503a61a43bd6df74d7d80855ebba7900ba158a2
MISC metadata.xml 453 BLAKE2B 2b04f47b565bbce71b1ddf27bedcd903f123751e7524ca62ea280b96788dbd14ae18513fda8eaf563d927c09dff7094b6a5c0d651c0530f2d3e07ee1d092c946 SHA512 5bb3c69c2dd5bc8ad2bc8c4a174be8627ed54ba0055bc153d36733f964ee289d71d0b392ec63127482a87f5f56fee9cf2900a2830a0ffbb733b1119be4abc0d3
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.2.4.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.2.4.ebuild
new file mode 100644
index 000000000000..aab80324cd45
--- /dev/null
+++ b/dev-python/python-sqlparse/python-sqlparse-0.2.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN##python-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="https://github.com/andialbrecht/sqlparse"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD-2"
+IUSE="doc test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+# Required for running tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+S="${WORKDIR}"/${P#python-}
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ if python_is_python3; then
+ 2to3 -w --no-diffs -n tests/ sqlparse/
+ py.test ./tests || die "testsuite failed ${EPYTHON}"
+ else
+ py.test tests || die "testsuite failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}