summaryrefslogtreecommitdiff
path: root/dev-python/python-socks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/python-socks
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest3
-rw-r--r--dev-python/python-socks/metadata.xml7
-rw-r--r--dev-python/python-socks/python-socks-1.1.0.ebuild32
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
new file mode 100644
index 000000000000..3776741723e4
--- /dev/null
+++ b/dev-python/python-socks/Manifest
@@ -0,0 +1,3 @@
+DIST python-socks-1.1.0.gh.tar.gz 1358296 BLAKE2B c599095a7f687ba1bba6f0ddbbc8ef2e680cb6be4e5d2250fad88c3a3273fb2044712045b20c5a358ed9dcbaef07e5133b6d672698d8caf4b978c9e633a5df70 SHA512 e38594815e5f943f810862dfe5d07a802601e41e879f68b4fa70c8087be0387a91e99e1b0578f2819557832b5e53be9773043a9617c72017c41e9377c4f35ef1
+EBUILD python-socks-1.1.0.ebuild 836 BLAKE2B 839d63a9d8791d200e38302ead37571a499beba21edc9ed2352c2b91d44fa4ca1e276f2aeda59969aa97f115657bf9c8fb249d4958c8a2bdf7f329cfddb9ecee SHA512 f82da47e50181ac065b9c5f1c5c8374be60e250dd765a63962ccfb7b220d05a9a048555c8863754a13a8b06f79eb39ad04ab3187d31a042d4061ed9f8c69bd35
+MISC metadata.xml 218 BLAKE2B 086fdcf7b63ca7bd6c58e861d717bb375e1cd372eff26d5d2eeeb176d8c5e6f10e653562abafb50eae7d7508f8e3d421b87e6a749acd0490308672828d0da697 SHA512 4558fee4c51117e21b1f42ca3edbdf1195ed297db798d6bfa0e5fbb7019654a187422b0abde7af5d800caffed66d1e55e4280e8be602bad591424d9776c46781
diff --git a/dev-python/python-socks/metadata.xml b/dev-python/python-socks/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/python-socks/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-socks/python-socks-1.1.0.ebuild b/dev-python/python-socks/python-socks-1.1.0.ebuild
new file mode 100644
index 000000000000..8efe7d9b3616
--- /dev/null
+++ b/dev-python/python-socks/python-socks-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# tests rely on connecting to Internet
+RESTRICT="test"
+
+# trio, curio are not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+#BDEPEND="
+# test? (
+# dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+# dev-python/yarl[${PYTHON_USEDEP}]
+# )"
+
+#distutils_enable_tests pytest