summaryrefslogtreecommitdiff
path: root/dev-python/python-socks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-08 23:39:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-08 23:39:55 +0100
commit2c359e29620429f94a60fc1e832048e54ee41eb5 (patch)
tree3a24152899725be0796179577e84caf957a80ce3 /dev-python/python-socks
parentd6a3ca89e16356791af128f18ca5d5aeaf1323e0 (diff)
gentoo auto-resync : 08:05:2023 - 23:39:55
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest2
-rw-r--r--dev-python/python-socks/python-socks-2.3.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 73502d675d58..b75a88b23970 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1,3 +1,5 @@
DIST python-socks-2.2.0.gh.tar.gz 32483 BLAKE2B 44dba93f29b3466515591bced694b1f17a76d7a9410829f8d4cfe0c4da18b00dddb9a84b37a9ce74dd20517a3567c06f4b96e4cc4724e88244dd11b097b3da9e SHA512 7189a249fcbc80c13f6070cd82d785ca4be48cbaf0a0e37da486b8517f551b9a22678a0c4d65f98adb30c719b5f47a3e9cd0133633a429283b04cdae089ed6a6
+DIST python-socks-2.3.0.gh.tar.gz 32506 BLAKE2B 0eaddbb4400488b6c96458d84671e69c9dd9bf927b9ea830d4161d4d78bdc32f66fb0c02f19e63afa868bd248a95d1544463bc877b79fd533b3952bfc71bef52 SHA512 792489d9daa63847733580b36d85d143146d0cd0b3f29297fa732516dea203b3f82deaf2779b56d80c20abe2739ed79e28a9a21cfeb26768ec557efef34c74f7
EBUILD python-socks-2.2.0.ebuild 1293 BLAKE2B 6e95a9c74f4e0d92231446e5f4b584d13ed195e61d077c3981260803415865bcdd14113be8c13658cca1a152e15f5d0463c45f3c0e806b0c76589a41337bdb3c SHA512 bfecbebe9f93fbc9ca98217d0fc62b34aaa44e19e4db44b271012a2bb8837e427e2fb760f94cdbdecd4593047fd99c658cf63412122ba8bfebfc1c4655c49376
+EBUILD python-socks-2.3.0.ebuild 1302 BLAKE2B 2d48b114ee0313b37d25328ca33ee8040b2365eeb2ff886727ae27007d5d6e4b08452deb1e32b099d957b44f520b08c93a74f806976d8e22eb6a9eabc2349d30 SHA512 f7f2a5c5aa375dfca24fecbcbe6015928bad9d98170483c8b7e06066d257dae039858ef69ba94046f6837025944a04374ee1293cc6da4f97deb6a01fb0ade9f1
MISC metadata.xml 380 BLAKE2B 2209abdbafd26baae585840e774843c37e0c6103fa93d75e8c1ddbc8dd1b96f269a3e76f14c39a55294d4d642d7fbe9f87c6b1a0b64152c671590a9e0a6ef959 SHA512 ccbb1a5c9fd05ae1da346f4f92efe156921f7adf9f5544635a407ba4a8154c896bda2e445e05e70a8e46c2829b8d4a38d3bf5d73804a3641c811acd2be62099a
diff --git a/dev-python/python-socks/python-socks-2.3.0.ebuild b/dev-python/python-socks/python-socks-2.3.0.ebuild
new file mode 100644
index 000000000000..71600c1a9cbc
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+# Test markers exist to exclude trio etc if needed
+distutils_enable_tests pytest