summaryrefslogtreecommitdiff
path: root/dev-python/python-socks/python-socks-2.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 13:51:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 13:51:21 +0000
commit4161fa7d1be6dac96e36f8ed343f234a8ef3a74f (patch)
treeee6d7260a8c03fb6191fead616b7dd50f07a7aa4 /dev-python/python-socks/python-socks-2.1.1.ebuild
parentef4d67f1907798e309efed58d673fd60594a14a8 (diff)
gentoo auto-resync : 20:12:2022 - 13:51:21
Diffstat (limited to 'dev-python/python-socks/python-socks-2.1.1.ebuild')
-rw-r--r--dev-python/python-socks/python-socks-2.1.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-socks/python-socks-2.1.1.ebuild b/dev-python/python-socks/python-socks-2.1.1.ebuild
new file mode 100644
index 000000000000..8dbc2cdbaa45
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest