summaryrefslogtreecommitdiff
path: root/dev-python/python-slugify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/python-slugify
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/python-slugify')
-rw-r--r--dev-python/python-slugify/Manifest3
-rw-r--r--dev-python/python-slugify/metadata.xml16
-rw-r--r--dev-python/python-slugify/python-slugify-1.2.6.ebuild23
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
new file mode 100644
index 000000000000..c8ed4f252bc2
--- /dev/null
+++ b/dev-python/python-slugify/Manifest
@@ -0,0 +1,3 @@
+DIST python-slugify-1.2.6.tar.gz 8439 BLAKE2B 74699bf80408e1b6a705525b0ada2612cc6224a2ac1e17ce21230ed684af144c0f72ad99b32674bf19bd716d2cfc3a2f0da6f74facc99acba16e3ebc1873f3f3 SHA512 ad45958d03892d8db75967b150f25509c05ab2a87d5ac4a2ed12fccccfe1f86d7db26c406c6de22ba759b77fe772cc0c00d0e517c71db085618f62094ddadfd2
+EBUILD python-slugify-1.2.6.ebuild 592 BLAKE2B 20da089bedc34e9c79c988035fb404624661eb730344293006f27c5e2c1b1df2a7d36dbe5640375fe8acfc43b59e11e5857ec601f5edf55ddbf457a169d59305 SHA512 a62b3eb4933fedf0456c5a94db14d4cc5076b51eb11f4a99b9a6dfbbb5792068d8bac92c913f23157a1ef42f80672d93389a1b480ce7fd058d70a22648298f7a
+MISC metadata.xml 503 BLAKE2B 57ca9410de0bb0833413a7005395601ecc9cc74f612f0bc0584e2c686a4df9b7477f057e17a567e360e7a70abc7ec82955a947972120f6637089780712ffbe23 SHA512 62a7512dc2ad3baaba77ade0fd6a22046cd6e950c340850a7e027ceda1d85eff063ec87427fe744369656703449d2670ea6c8f555d27bace6c330d00aabd4651
diff --git a/dev-python/python-slugify/metadata.xml b/dev-python/python-slugify/metadata.xml
new file mode 100644
index 000000000000..8ba37583de7b
--- /dev/null
+++ b/dev-python/python-slugify/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo.2019@r123.de</email>
+ <name>Robert Siebeck</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-slugify</remote-id>
+ <remote-id type="github">un33k/python-slugify</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-slugify/python-slugify-1.2.6.ebuild b/dev-python/python-slugify/python-slugify-1.2.6.ebuild
new file mode 100644
index 000000000000..569e6c07989d
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-1.2.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="https://github.com/un33k/python-slugify https://pypi.org/project/python-slugify/"
+SRC_URI="https://github.com/un33k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/unidecode[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest