summaryrefslogtreecommitdiff
path: root/dev-python/python-sense-hat/python-sense-hat-2.2.0-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/python-sense-hat/python-sense-hat-2.2.0-r3.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/python-sense-hat/python-sense-hat-2.2.0-r3.ebuild')
-rw-r--r--dev-python/python-sense-hat/python-sense-hat-2.2.0-r3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-sense-hat/python-sense-hat-2.2.0-r3.ebuild b/dev-python/python-sense-hat/python-sense-hat-2.2.0-r3.ebuild
new file mode 100644
index 000000000000..b6ffda3de655
--- /dev/null
+++ b/dev-python/python-sense-hat/python-sense-hat-2.2.0-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Raspberry Pi Sense HAT python library"
+HOMEPAGE="https://github.com/astro-pi/python-sense-hat"
+SRC_URI="https://github.com/astro-pi/python-sense-hat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="arm arm64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/rtimulib[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"