summaryrefslogtreecommitdiff
path: root/dev-python/python-saharaclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-saharaclient
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-saharaclient')
-rw-r--r--dev-python/python-saharaclient/Manifest5
-rw-r--r--dev-python/python-saharaclient/metadata.xml19
-rw-r--r--dev-python/python-saharaclient/python-saharaclient-1.1.0.ebuild55
-rw-r--r--dev-python/python-saharaclient/python-saharaclient-1.5.0.ebuild58
4 files changed, 137 insertions, 0 deletions
diff --git a/dev-python/python-saharaclient/Manifest b/dev-python/python-saharaclient/Manifest
new file mode 100644
index 000000000000..65be2461dffe
--- /dev/null
+++ b/dev-python/python-saharaclient/Manifest
@@ -0,0 +1,5 @@
+DIST python-saharaclient-1.1.0.tar.gz 81664 BLAKE2B 8bfc8ed2bcc4cc13e6894d7776f7cb99c8a72632e132801df689832ef847c56b7cedf39abb112223a2919ea3ef52fc99e31290f7acb555f76505e11f195c48db SHA512 0799549d68bc65792cdf0129f3590667a1a87697182ad24c5c41e9c01abf5e133a16a60fe0331f313da44017aaf0503bbc131e8a62536a692032af36ae9f1386
+DIST python-saharaclient-1.5.0.tar.gz 94824 BLAKE2B cacc3f2e8a1df5f7e50f5b5c004745333ea4b287c0a86792247212fb873ec55329719f16472c3c7fef196f2ce8fd05c760e8db33b84e0ea949f7e89997c0f960 SHA512 8b845ad0eefa05b564659dea9e619a3946e0d62a981b46a4fecfc2d4aab785b8eeb2e18266d5467efd8e0ca31c441af7da41a816ea42405a8cd137adeae2793b
+EBUILD python-saharaclient-1.1.0.ebuild 1842 BLAKE2B 9d511aa66b3661003bdca93728df0ba6aef555f9b8edc0a15cefe1c8c15c14f13048ac93ef999d9d9342eefdee07380f3c651483c6846621b7fd5897fa5f1104 SHA512 8c59dca5e42f64c89b94496e7cdea8ab02ef332d15591f2c41ad9633dc6d64fc658a82b70e5317b1dfd9b9ef72e05ca12fafecb74257fb30ccdb8e15b2c9c438
+EBUILD python-saharaclient-1.5.0.ebuild 1992 BLAKE2B d1fd246dd60208a12053f8af26825566a88ab8b74ec3de928bbb085eff187b30ea54fcd75a8eaab9656b20e0a0593a4a1c0379749d99302ae8fbe8da085509b6 SHA512 9c9054e960ddadbdcbdcc28b51f326e39cb9b9b6730f91ad2863e9c2c98208c2871ff0a62f67bdd8b5439d5138514d0b442f24aa45f78de49b4e4e13c091704d
+MISC metadata.xml 643 BLAKE2B 2a3c45ea4f9fa3c045cb88796e093436e66719daf71739c7679882f11123f2ac405926c8405046aed4efb55328d7235619192b9b7f978f7571c673e306953834 SHA512 4ab105b6287560e19a7b6ba8e999da16bdb520ff8f1a812e0e17ebff9c1edd2f7ec1475978ee478c556d31af8c201555669c92ff388de45a206b45005ec95d2c
diff --git a/dev-python/python-saharaclient/metadata.xml b/dev-python/python-saharaclient/metadata.xml
new file mode 100644
index 000000000000..0c5d6367e225
--- /dev/null
+++ b/dev-python/python-saharaclient/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a client for the OpenStack Sahara API, aka HADOOP
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">python-saharaclient</remote-id>
+ <remote-id type="github">openstack/python-saharaclient</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-saharaclient/python-saharaclient-1.1.0.ebuild b/dev-python/python-saharaclient/python-saharaclient-1.1.0.ebuild
new file mode 100644
index 000000000000..6093ccd41c5d
--- /dev/null
+++ b/dev-python/python-saharaclient/python-saharaclient-1.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client for the OpenStack Sahara API, aka HADOOP"
+HOMEPAGE="https://github.com/openstack/python-saharaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/os-testr-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.11.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testr init
+ testr run --parallel || die "testsuite failed under python2.7"
+}
diff --git a/dev-python/python-saharaclient/python-saharaclient-1.5.0.ebuild b/dev-python/python-saharaclient/python-saharaclient-1.5.0.ebuild
new file mode 100644
index 000000000000..7cb3064d30ea
--- /dev/null
+++ b/dev-python/python-saharaclient/python-saharaclient-1.5.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client for the OpenStack Sahara API, aka HADOOP"
+HOMEPAGE="https://github.com/openstack/python-saharaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/os-testr-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testr init
+ testr run --parallel || die "testsuite failed under python2.7"
+}