summaryrefslogtreecommitdiff
path: root/dev-python/python-recurring-ical-events
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-17 17:55:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-17 17:55:18 +0000
commit0bc41c955151f7b962f67f03e18e580620f91bd6 (patch)
tree834073a4e0c66ae35e5b891a763832075aad475f /dev-python/python-recurring-ical-events
parente54e6bf2ec8cc0fb912bffefee5b3d22cd3fcd9c (diff)
gentoo auto-resync : 17:01:2023 - 17:55:17
Diffstat (limited to 'dev-python/python-recurring-ical-events')
-rw-r--r--dev-python/python-recurring-ical-events/Manifest3
-rw-r--r--dev-python/python-recurring-ical-events/metadata.xml13
-rw-r--r--dev-python/python-recurring-ical-events/python-recurring-ical-events-2.0.0.ebuild43
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/python-recurring-ical-events/Manifest b/dev-python/python-recurring-ical-events/Manifest
new file mode 100644
index 000000000000..e16bd5c065b3
--- /dev/null
+++ b/dev-python/python-recurring-ical-events/Manifest
@@ -0,0 +1,3 @@
+DIST python-recurring-ical-events-2.0.0.gh.tar.gz 325608 BLAKE2B 386ab8a54343fb02c15938801c15b31c8c8ba6bd0888a677268625fcba5571724d53c42f9d093ea8590d6e3557c151b73f9fb532a1bea194bc6d7032e04946e9 SHA512 676bc074a4d9ddb2bf0aefe8e118eab6e80479bb0d585b9f4c50f4bd49c7adf03e484b34bdf01596bb012c903a8017644ff74026d333f13f5c7df2c4326ab18c
+EBUILD python-recurring-ical-events-2.0.0.ebuild 1085 BLAKE2B 8ddeaed90db3c979a2c3160bc6b1aa459816212775817ebd36ff1612a8fa5cf79e0369bbb41a964de7d5dae5bad0aabd11f360de2892f85cd3611946ac70eadf SHA512 9a447108732624a6af89d6e4632d2aac7fd9ba117689d9c5aeeecb073dc7dcc8c83e3e80eb69a0cdec606fef1ccebeca6793ad404109005d406dab3b2e742ac7
+MISC metadata.xml 431 BLAKE2B 19ac0f0a385fb9b0524bf641831fbe3c02f35f3ada35922b297563f871cb8e745404e04d18d9f7428ef5b3cca27f5205f4a7f99e85e2a3da18542a19574f04de SHA512 35283cfbd447b3ec9d0d97ec7c11580db012ee60076b12ba733962d58896203a162ece04a9015eca8cc556f28fac307fc9ddeb27c3ea9cb9c8b2d6df0cf93a50
diff --git a/dev-python/python-recurring-ical-events/metadata.xml b/dev-python/python-recurring-ical-events/metadata.xml
new file mode 100644
index 000000000000..3c5c8d8ba58d
--- /dev/null
+++ b/dev-python/python-recurring-ical-events/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">niccokunzmann/python-recurring-ical-events</remote-id>
+ <remote-id type="pypi">recurring-ical-events</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-recurring-ical-events/python-recurring-ical-events-2.0.0.ebuild b/dev-python/python-recurring-ical-events/python-recurring-ical-events-2.0.0.ebuild
new file mode 100644
index 000000000000..0787572abca4
--- /dev/null
+++ b/dev-python/python-recurring-ical-events/python-recurring-ical-events-2.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)
+
+EPYTEST_DESELECT=(
+ # a test checking if tzdata package is installed that is apparently
+ # needed for other tests, except it isn't
+ test/test_zoneinfo_issue_57.py::test_zoneinfo_must_be_installed_if_it_is_possible
+)