summaryrefslogtreecommitdiff
path: root/dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
commit1426dfeb15e4d49cb4238c6cf37455a6130cd83f (patch)
tree9f9734bcdc280108e52d753b3c57234371772c3c /dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch
parent836586553c510ee2dd91e2ecd7676fe432c1f1a4 (diff)
gentoo auto-resync : 18:09:2023 - 11:05:42
Diffstat (limited to 'dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch')
-rw-r--r--dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch b/dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch
new file mode 100644
index 000000000000..fc7e55f6160e
--- /dev/null
+++ b/dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch
@@ -0,0 +1,30 @@
+Upstream: https://github.com/vstinner/python-ptrace/pull/81
+commit 80e0c97a84eccb8b82737cf40b9c5581c20c245f
+Author: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Sat Sep 16 13:49:43 2023 +0200
+
+ Remove deprecated `imp` module
+
+--- a/setup.py
++++ b/setup.py
+@@ -28,7 +28,7 @@
+ # - git commit -a -m "post-release"
+ # - git push
+
+-from imp import load_source
++import importlib.util
+ from os import path
+ try:
+ # setuptools supports bdist_wheel
+@@ -55,7 +55,10 @@ CLASSIFIERS = [
+ with open('README.rst') as fp:
+ LONG_DESCRIPTION = fp.read()
+
+-ptrace = load_source("version", path.join("ptrace", "version.py"))
++ptrace_spec = importlib.util.spec_from_file_location("version", path.join("ptrace", "version.py"))
++ptrace = importlib.util.module_from_spec(ptrace_spec)
++ptrace_spec.loader.exec_module(ptrace)
++
+ PACKAGES = {}
+ for name in MODULES:
+ PACKAGES[name] = name.replace(".", "/")