summaryrefslogtreecommitdiff
path: root/dev-python/python-msrplib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-msrplib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-msrplib')
-rw-r--r--dev-python/python-msrplib/Manifest3
-rw-r--r--dev-python/python-msrplib/metadata.xml29
-rw-r--r--dev-python/python-msrplib/python-msrplib-0.18.0.ebuild26
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/python-msrplib/Manifest b/dev-python/python-msrplib/Manifest
new file mode 100644
index 000000000000..8b6a7415f5dc
--- /dev/null
+++ b/dev-python/python-msrplib/Manifest
@@ -0,0 +1,3 @@
+DIST python-msrplib-0.18.0.tar.gz 30234 BLAKE2B da90d00291ab68ae5e4e89f275367741d8dac21e2cb35b6b9722430147b5ada1802c943b5e224f36d565faab216c649cc6e155fc1aaf23ab2f63d3c6e39bf2a7 SHA512 ed260b0183aff543e115951f464d0e3934862439a7c049c3d19304c543805ee364129d2a99c0d132561c8ae0af9fc19cde460723f2754e973bf68a602a18db99
+EBUILD python-msrplib-0.18.0.ebuild 652 BLAKE2B a0ebf5ac45b0416078de98f7adff7c7bb2a977b9e24544785f94175a3cc7c413079b3d7cc56b7bc43173ef8b2ed3f29e37e323c92dcded7f5e7e7941a758df8c SHA512 c0792e7f617fd118d44b6bef4434d65988b28e51bb406b6bfa480ba699483121266e461e234a641f60f574b8f3d9cf6f3cca2874ae0982fd35191ef7280d6080
+MISC metadata.xml 1408 BLAKE2B 54f95b890ad88c030d28c59494c9f330aa29fb114aaea3a1c474a4c5e06e2937acb50d9b31cf08f970fc91c57e18e11e9788bdf48d4aa14991ab1ec3e17cfe58 SHA512 09c18e4112893d9598b9d56ba1f2fdfad5dfc78e5a97da0b65f3c00b2cc0ad673f68e94e50dda12c8be506e455f47ec5fd8bb00411ab205221241c6cf4b26f8c
diff --git a/dev-python/python-msrplib/metadata.xml b/dev-python/python-msrplib/metadata.xml
new file mode 100644
index 000000000000..d854883a141e
--- /dev/null
+++ b/dev-python/python-msrplib/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Message Session Relay Protocol (MSRP) is a protocol for transmitting a
+ series of related instant messages in the context of a session. Message
+ sessions are treated like any other media stream when set up via a
+ rendezvous or session creation protocol such as the Session Initiation
+ Protocol (SIP).
+
+ A series of related instant messages between two or more parties can be
+ viewed as part of a "message session", that is, a conversational exchange
+ of messages with a definite beginning and end. This is in contrast to
+ individual messages each sent independently. Messaging schemes that track
+ only individual messages can be described as "page-mode" messaging,
+ whereas messaging that is part of a "session" with a definite start and
+ end is called "session-mode" messaging.
+
+ Page-mode messaging is enabled in SIP via the SIP MESSAGE method, as
+ defined in RFC 3428. Session-mode messaging has a number of benefits
+ over page-mode messaging, however, such as explicit rendezvous, tighter
+ integration with other media-types, direct client-to-client operation,
+ and brokered privacy and security.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-msrplib/python-msrplib-0.18.0.ebuild b/dev-python/python-msrplib/python-msrplib-0.18.0.ebuild
new file mode 100644
index 000000000000..cc0e91b26aed
--- /dev/null
+++ b/dev-python/python-msrplib/python-msrplib-0.18.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Client library for MSRP protocol and its relay extension"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/MSRP/python-msrplib-${PV}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/python-application[${PYTHON_USEDEP}]
+ dev-python/python-eventlib[${PYTHON_USEDEP}]
+ dev-python/python-gnutls[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-names[${PYTHON_USEDEP}]
+"