summaryrefslogtreecommitdiff
path: root/dev-python/python-mpv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
commit6cdde4bf2702fac82ba7163fe9f922e7fa0b9a66 (patch)
tree876fe918d1abfd24cf9323208d2929b94a47cfc7 /dev-python/python-mpv
parentce89e807ecd2194613ad6e6bcee8cf95e982ad1a (diff)
gentoo auto-resync : 18:11:2023 - 17:04:41
Diffstat (limited to 'dev-python/python-mpv')
-rw-r--r--dev-python/python-mpv/Manifest2
-rw-r--r--dev-python/python-mpv/python-mpv-1.0.5.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-mpv/Manifest b/dev-python/python-mpv/Manifest
index e5ec902c4834..1e9edbe610dd 100644
--- a/dev-python/python-mpv/Manifest
+++ b/dev-python/python-mpv/Manifest
@@ -1,3 +1,5 @@
DIST python-mpv-1.0.4.gh.tar.gz 211628 BLAKE2B cb3b9042648ffd0472093f84116084f255893ab7068379a01011e8153da9c60c525c9b701e8f0be29ebbfaca9da9b4fd0024741e7b243b13c3b9e69f597dede8 SHA512 d8bab1373961ef52645f0886f317e8a1328a9d737c1a7de77d0f348a31822daa3120b79d9fd8e969c971b1de9c30fdd40aa120c8775ad3110f5a11ab9992ae7c
+DIST python-mpv-1.0.5.gh.tar.gz 211622 BLAKE2B eeda4e61c8e2728898ddae7c2cd9e92a7cf718b22aefd8104edf361b7d7feab7655561019cbed35045cbdc4faac96e0d85c77d053bfae61e05052a981bd00342 SHA512 cefc0b38146d707a06e2b9e58951675be8d236c95e24de7665085641b24f7d7d5303130ebdb4c97f4f4c79b6de393c30656d9fc0dabf6760156d4aca8207d77c
EBUILD python-mpv-1.0.4.ebuild 819 BLAKE2B 9f4f680cf185f1b727e3ddfb9457b06e06c3de2f69f1409205c1379658075a2725c6296168b9b1d38aad357da4a1960608300e330c66000a86ee794a89b8210f SHA512 d55d2381485d7725923ca6c262576dc783eb90e9b06d56ac7a6a0da7c0d49d000fe759a9e982f1796499826a1c21cdeeeb79ed63ae0a0635c9f95f42ba913e85
+EBUILD python-mpv-1.0.5.ebuild 880 BLAKE2B a8cf75a148c1c2083cab42433d74dc023264ad83676380828bc85a6bcab7f3513936c0c26b04f2157a876d2ccb6f147be51d715ff2a38a2130c5e635ef2740ad SHA512 aba497993aa54cd36c70ea1d09082663e9ec08e0ce84adce0bcf026be143e383bd6f8bfb33a8cbc2cdddb42c7c91b4a10a2a1df4732937b987a29e46d6e2da85
MISC metadata.xml 413 BLAKE2B 3e6ced6a506525bd576741fbcb1b0ce6069492dd1e90295a46b029340b833d981b351ac717e3896f4b13f3e8635065e974317298711922ab131925d98d0447a3 SHA512 9426ddc828c6b8f420c3d0241f827dd7746ca797c45182b0324b8278a24e4038a856494b420de2de572ee2643082ae271a5c21030098432736255ff2f6798db3
diff --git a/dev-python/python-mpv/python-mpv-1.0.5.ebuild b/dev-python/python-mpv/python-mpv-1.0.5.ebuild
new file mode 100644
index 000000000000..bc051b93bc18
--- /dev/null
+++ b/dev-python/python-mpv/python-mpv-1.0.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python interface to the mpv media player"
+HOMEPAGE="
+ https://github.com/jaseg/python-mpv/
+ https://pypi.org/project/python-mpv/
+"
+SRC_URI="
+ https://github.com/jaseg/python-mpv/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-video/mpv[libmpv]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # hanging tests
+ tests/test_mpv.py::TestLifecycle::test_wait_for_property_event_overflow
+ tests/test_mpv.py::TestStreams::test_custom_stream
+ )
+
+ virtx epytest
+}