summaryrefslogtreecommitdiff
path: root/dev-python/python-mpd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/python-mpd
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/python-mpd')
-rw-r--r--dev-python/python-mpd/Manifest4
-rw-r--r--dev-python/python-mpd/metadata.xml2
-rw-r--r--dev-python/python-mpd/python-mpd-3.0.4.ebuild46
3 files changed, 50 insertions, 2 deletions
diff --git a/dev-python/python-mpd/Manifest b/dev-python/python-mpd/Manifest
index 3d3b6e4f43b7..f5dceccf7c0a 100644
--- a/dev-python/python-mpd/Manifest
+++ b/dev-python/python-mpd/Manifest
@@ -1,3 +1,5 @@
DIST python-mpd-1.1.0.tar.gz 61104 BLAKE2B 274a829a3fc1404a4e3beb4df3eb563c1f781325590702761d3b3b5bc42e3cd9f63809aab14bb98e4879c10ccd55bb9d7306485ec22d37538cc2e36006a3039a SHA512 65b17ae34b2c731b7d45801211e49eacfc18239d5575075be0c11ace350da19b82dd151fefc42077454a988d3deb1b489471f739ddea2d915cb3c241669dbe32
+DIST python-mpd2-3.0.4.tar.gz 66173 BLAKE2B f92a97512f19ac5f71846d3997240e5a37a4fd9bc353e131c582547ddc6e9520d2d09a02b4de62168707ba4a2cbfc28a019cba7e0a113242ecc38ecdc86c19a9 SHA512 7adf0daf64c6132dcd4d347f0772e9cbef903f9f5fba5315b745708dd2179090f53c5303b7ce905c685076861d21f7a14951e598c88eb65be423dea627dbb26a
EBUILD python-mpd-1.1.0-r1.ebuild 1018 BLAKE2B 783f979d5b5c81ec40e7640090270c20c2c13fe46df0976a1cf733aaa2242b55a6004ceb682e5dded105497392bbfe41a883c7f71b19825fd7cd1c43a094d18b SHA512 773b5221e9947275421db704478526a182089f3e430140fac7d55e425f042df8b216d419cf0ac908fb4e835114b80a4567df6fcd55a458268889ccc4c20552a1
-MISC metadata.xml 462 BLAKE2B 7ab5f8dbe5062af562e466d8c9452e29072c1d91ac10eb7adf05f81f9c7ab7cb28a2a81f6a80791c782aeac33a863ab26a17e88c0bde408db084b29fb8fdc592 SHA512 2c3220c6a6efe353ff1d667b8689f673c66ee58176a140437237cd74fe02c794bcdc219dd658f8e77d5f338a6c877890d09d28d87580cef36946011aaffa4cac
+EBUILD python-mpd-3.0.4.ebuild 964 BLAKE2B 2be1c94bd5feb7e3cec3d8edafc8a5987a9dde43c72b2e3ba576a05cde34c7dd5fdfa267fe9526b1a741537328729316dc8acd20a3edfe699f9f533acb35c9c4 SHA512 bb7e740ec38e50938af2d4a4a41496f85d70311856a5fa97091c8b435777225413faa4c35b41d674414e21237a0748b3a3b5e3c9e71cecba3c5ab488b06ccd1a
+MISC metadata.xml 463 BLAKE2B 9f711c66d5ac55f12770a73ec22e9f444ce861532624a17efd2ad8e31bbb77eee4d4608a8bac331eef5e9da009a840cb03c4723a5ee52c547089c6c61a248a94 SHA512 98ffedc8e05168b8a2a0e193655c20d41e40d69e652ca0d443c932f8c35630434e93aa76c2a03029c96f2c96f54c432c384ece12c6645f8cada73f8a76263710
diff --git a/dev-python/python-mpd/metadata.xml b/dev-python/python-mpd/metadata.xml
index 5f48b4f8480e..589c1826e37f 100644
--- a/dev-python/python-mpd/metadata.xml
+++ b/dev-python/python-mpd/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="pypi">python-mpd</remote-id>
+ <remote-id type="pypi">python-mpd2</remote-id>
<remote-id type="github">Mic92/python-mpd2</remote-id>
</upstream>
<use>
diff --git a/dev-python/python-mpd/python-mpd-3.0.4.ebuild b/dev-python/python-mpd/python-mpd-3.0.4.ebuild
new file mode 100644
index 000000000000..82c66c86e910
--- /dev/null
+++ b/dev-python/python-mpd/python-mpd-3.0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_P=python-mpd2-${PV}
+DESCRIPTION="Python MPD client library"
+HOMEPAGE="
+ https://github.com/Mic92/python-mpd2/
+ https://pypi.org/project/python-mpd2/"
+SRC_URI="
+ https://github.com/Mic92/python-mpd2/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="examples +twisted"
+
+RDEPEND="twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst doc/{changes.rst,commands_header.txt} doc/topics/. )
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ epytest mpd/tests.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples/.
+}