summaryrefslogtreecommitdiff
path: root/dev-python/python-meteor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-meteor
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-meteor')
-rw-r--r--dev-python/python-meteor/Manifest3
-rw-r--r--dev-python/python-meteor/metadata.xml17
-rw-r--r--dev-python/python-meteor/python-meteor-0.1.6.ebuild22
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/python-meteor/Manifest b/dev-python/python-meteor/Manifest
new file mode 100644
index 000000000000..932c2e797c86
--- /dev/null
+++ b/dev-python/python-meteor/Manifest
@@ -0,0 +1,3 @@
+DIST python-meteor-0.1.6.tar.gz 7656 BLAKE2B c1ab81da13d3f2903779b07680a0ea96d03ac4f38f3a96c8317bcee60fd50f2f7e468fccda1731b22d88632da63b83cd9d69d83725cf90e2cd992bb9be5a39a6 SHA512 c654113714e7a4311d66d7390a996cce126bed2270e15f22791ddb8cec1afd5af321f24c8a83d8dc491c0959b8410fa91d43e2025534390486283f2da78a2233
+EBUILD python-meteor-0.1.6.ebuild 494 BLAKE2B f92b0441c820b7a0590ed9029c210f6ac1f583f663e3535a0c4cbb2e8a65bbfe2a3ebd12ef22423b3b6dc31d2648b7397bb0f7a2a07f419c6877fa690c3fec03 SHA512 0d3a6ce373335f57b734eb3a190612401f58fe11b06627d73a5ee28b2fbfc8d7b36035c2e8edd638d18b2d98a251db6fe5d74d9159bc3e90aaa6c57b844c3149
+MISC metadata.xml 584 BLAKE2B 25317aa7374c2da162d3f167ad05e183880015ac0978cddb21504c03a63ff1f1e1f9f951f21e3846f2c289926e36328bd2571bd16a5a1c27e602a503e2abca04 SHA512 73e3dc166d3e4f019fb9c12a4374a7537fa2529fee80a3ee83f74e75fc790b14dcbe209d171889f6c1f13ada3d510cfa6fd0525aefc02567d95869e2da1f9191
diff --git a/dev-python/python-meteor/metadata.xml b/dev-python/python-meteor/metadata.xml
new file mode 100644
index 000000000000..484ef70351c2
--- /dev/null
+++ b/dev-python/python-meteor/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-meteor</remote-id>
+ <remote-id type="github">hharnisc/python-meteor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-meteor/python-meteor-0.1.6.ebuild b/dev-python/python-meteor/python-meteor-0.1.6.ebuild
new file mode 100644
index 000000000000..a250eb0a8fa3
--- /dev/null
+++ b/dev-python/python-meteor/python-meteor-0.1.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="An event driven meteor client"
+HOMEPAGE="https://pypi.org/project/python-meteor/ https://github.com/hharnisc/python-meteor"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/python-ddp[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"