summaryrefslogtreecommitdiff
path: root/dev-python/python-meteor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-meteor
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-meteor')
-rw-r--r--dev-python/python-meteor/Manifest4
-rw-r--r--dev-python/python-meteor/metadata.xml17
-rw-r--r--dev-python/python-meteor/python-meteor-0.1.6.ebuild22
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/python-meteor/Manifest b/dev-python/python-meteor/Manifest
new file mode 100644
index 000000000000..56c5d837426a
--- /dev/null
+++ b/dev-python/python-meteor/Manifest
@@ -0,0 +1,4 @@
+DIST python-meteor-0.1.6.tar.gz 7656 SHA256 014bd2fd61e73e8f67892a0114fbcb3185db3bc74f70990379aedb5b359a8667 SHA512 c654113714e7a4311d66d7390a996cce126bed2270e15f22791ddb8cec1afd5af321f24c8a83d8dc491c0959b8410fa91d43e2025534390486283f2da78a2233 WHIRLPOOL ab22fe7e64948b2c14aba8c67b36d1426b2183fb87a2c945521c81917f7d231a099101e1ff09a4d2a0e98565ad02947adebabf242ab11137e8a79f0bed2357ac
+EBUILD python-meteor-0.1.6.ebuild 493 SHA256 8779f56ec39e6b80a10702d499dae00f53be81f15eb1db0235ea6b0c1fb87ec3 SHA512 ddc0a0f44cdd42801c18d6ef7878065431c04b0606fa6df946d5d40db1b9a60e091bcadd0ab9ca2b3b5a268de5157ea7220e08a2d2867a7bc6a6084b85f057d2 WHIRLPOOL c5e22d9a007fd90990a378e5cc4385c02a83636d25b7ad5b3fd6d54e3fee7faa4dfd71ccdc4f82206b400fc4de56b03391fce77aadc8aa9e4857c69e65ab7e48
+MISC ChangeLog 1313 SHA256 e8cdf4fb9f317a88b105b4910a772a42cd71f0d8c5fbef26aa56ea526856342c SHA512 6d699539801e171d93811b790cda907bee6735e89ba054862a7cdba42b08ea2ba6a137888565debb5e240141bc894683100efef1fce707ff66fbbd5ca91a367f WHIRLPOOL b4ed8598bd4ee9c26ef69dc182f42cc4661bebf4ff64d391f04910978224c56d8f1d290c91545bdd57ab91a252b265e0d755d5439da98b6ed5497b18255c5df4
+MISC metadata.xml 584 SHA256 2a21a6f2a85ea4b550b17499946f61731380018c066f96f12a79f633ceead26b SHA512 73e3dc166d3e4f019fb9c12a4374a7537fa2529fee80a3ee83f74e75fc790b14dcbe209d171889f6c1f13ada3d510cfa6fd0525aefc02567d95869e2da1f9191 WHIRLPOOL 60c55bdccc074ace9e1035a745fbf742689b16023c538dd4ca43b1d607346406deee669f23375a47155eb34edbe46838b991cc32954b2282cebbef304c675326
diff --git a/dev-python/python-meteor/metadata.xml b/dev-python/python-meteor/metadata.xml
new file mode 100644
index 000000000000..484ef70351c2
--- /dev/null
+++ b/dev-python/python-meteor/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-meteor</remote-id>
+ <remote-id type="github">hharnisc/python-meteor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-meteor/python-meteor-0.1.6.ebuild b/dev-python/python-meteor/python-meteor-0.1.6.ebuild
new file mode 100644
index 000000000000..609739016d7b
--- /dev/null
+++ b/dev-python/python-meteor/python-meteor-0.1.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="An event driven meteor client"
+HOMEPAGE="https://pypi.python.org/pypi/python-meteor https://github.com/hharnisc/python-meteor"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/python-ddp[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"