summaryrefslogtreecommitdiff
path: root/dev-python/python-memcached/python-memcached-1.59-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-13 13:10:51 +0000
commit7860ad41012a3808c645607818b64ad7dab025e9 (patch)
tree102565176c19f5aef57ae4f6faecd3bded6f36ee /dev-python/python-memcached/python-memcached-1.59-r2.ebuild
parentb83f9f17a27e03508085814208cd9c89a07f1f49 (diff)
gentoo auto-resync : 13:01:2024 - 13:10:51
Diffstat (limited to 'dev-python/python-memcached/python-memcached-1.59-r2.ebuild')
-rw-r--r--dev-python/python-memcached/python-memcached-1.59-r2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/python-memcached/python-memcached-1.59-r2.ebuild b/dev-python/python-memcached/python-memcached-1.59-r2.ebuild
deleted file mode 100644
index 2d234212dcdc..000000000000
--- a/dev-python/python-memcached/python-memcached-1.59-r2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure python memcached client"
-HOMEPAGE="
- https://github.com/linsomniac/python-memcached/
- https://pypi.org/project/python-memcached/
-"
-SRC_URI="
- https://github.com/linsomniac/python-memcached/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="PSF-2.4"
-SLOT="0"
-KEYWORDS="amd64 arm64 ppc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- net-misc/memcached
- )
-"
-
-distutils_enable_tests unittest
-
-python_test() {
- local pidfile="${TMPDIR}/memcached.pid"
-
- memcached -d -P "${pidfile}" || die "failed to start memcached"
-
- eunittest || die "Tests fail with ${EPYTHON}"
-
- kill "$(<"${pidfile}")" || die "failed to kill memcached"
- local elapsed=0
- while [[ -f ${pidfile} ]]; do
- if [[ $(( elapsed++ )) -ge 30 ]]; then
- kill -KILL "$(<"${pidfile}")" ||
- die "failed to kill -KILL memcached"
- die "memcached failed to stop after 30 seconds"
- fi
- sleep 1
- done
-}