summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-jsonrpc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-09 22:25:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-09 22:25:44 +0100
commit796e724b5ace96ff70d918765662edf62f1d8c85 (patch)
treeb09742996db0de2a2414587542b1b91d4ae5c522 /dev-python/python-lsp-jsonrpc
parentcd7ab3ad114e9777d85ced67abdd5b25d0bd4efe (diff)
gentoo auto-resync : 09:07:2023 - 22:25:43
Diffstat (limited to 'dev-python/python-lsp-jsonrpc')
-rw-r--r--dev-python/python-lsp-jsonrpc/Manifest1
-rw-r--r--dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.0.0-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-lsp-jsonrpc/Manifest b/dev-python/python-lsp-jsonrpc/Manifest
index ac21f53b11f2..7bda02097dc7 100644
--- a/dev-python/python-lsp-jsonrpc/Manifest
+++ b/dev-python/python-lsp-jsonrpc/Manifest
@@ -1,4 +1,5 @@
AUX python-lsp-jsonrpc-1.0.0-fix-test-with-ujson-3-and-up.patch 342 BLAKE2B aafe30896b88531102ff79900d845a24a506ff8d0649699311e77f9ba6742f591500e2cb83a2e5aff3118a1174819b2745a8f9ca6919af8b84d379422c7e06b7 SHA512 baaa0105df9906d451a9870c7f0ca5980c6b667b7d8c4fb4f57a0fb3bfbd3f2b7502cfeea7f2abb041c2dcb344f6f5ef69822d82daed3de1ebe4564c812c7430
DIST python-lsp-jsonrpc-1.0.0.tar.gz 10011 BLAKE2B 671490d439f10eebf2d05f221adad25be6f881f4a0f4fa975d4574937a951d4d0bc51264a9ec67d3ef5d112b6e025b551685d3e3c2b959c4a6bcef92d46c5ff3 SHA512 447835fc6c3810f486d80f85295089c021b792843bdf88d461c021b8b04407d8f7e6a99c07351a23658a5dff46eb475bc64e51bdec029787cd33330b54d4dfec
+EBUILD python-lsp-jsonrpc-1.0.0-r1.ebuild 774 BLAKE2B eeb4a1618a60b061d70791b628710038718f99d1b2fcff348924d561d93ec27ba2ccdc1fdecdc1ab97253a8bc76881c59e2c298a5baf27347c3f5be2e92058b5 SHA512 2788b9f8a5ed9e644ca64b76d2a91ada2efd8df55b899f5c87a96344e35beb620cf5363bce13b0722b56c510f3c5995062c86047f7ab3161ef37c07ca52f51bd
EBUILD python-lsp-jsonrpc-1.0.0.ebuild 741 BLAKE2B 03454ef44ad56ecea266471ea2d70159ec8d4faf78a02089eac663f415d946a7014954e73d4bb65b056304e27665dde317b9b0c5a00f305dce995b75ed597c1b SHA512 21ec7cf35e3bf786cd9c662b05dfa107bbb7d09f0a90d48cc92ff4fb4913634133ec126108fce41e69d8cf8e3cf6659ccedfdc21a3aa0ab081cec56b64383bee
MISC metadata.xml 465 BLAKE2B c1c85dc7e2694420f8fcb80c4de578d159fa124b3cf7388d66220b6425ca6a11bad88b3ed91f5272f81a2604dd68009e4076a5d800585a2e4e6f9c448eb25a8e SHA512 16456c751af90b7169978398771635459406029275332d569304f9369ecd0ee5b4cb1e269c9a22c5b636d72e6c5f685f55e5f6b73a62b730c2b8c8734ba971bd
diff --git a/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.0.0-r1.ebuild b/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..b34374ec9df3
--- /dev/null
+++ b/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.0.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="JSON RPC 2.0 server library"
+HOMEPAGE="https://github.com/python-lsp/python-lsp-jsonrpc"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=">=dev-python/ujson-3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}/${P}-fix-test-with-ujson-3-and-up.patch" )
+
+python_prepare_all() {
+ # Remove pytest-cov dep
+ sed -i -e '0,/addopts/I!d' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}